Skip to:
Content
Pages
Categories
Search
Top
Bottom

Seeing "Page Not Found" on Activity, Members, Groups & Blogs tabs.

  • Avatar of paul1664
    paul1664
    Member

    @paul1664

    Hi,

    I have installed WPMU & BP on my server (IIS7, latest PHP & MySql) and everything works great on the first site.

    If I proceed to install further blogs then the BP Activity, Members, Groups & Blogs tabs give me a Page Not Found error. Note that the rest of the page renders correctly and appears in the BuddyPress style theme, so its not a ‘server error 404′ type error, and the Home and About tabs display correctly.

    I’m guessing this is a permalink or url problem as I get a fresh (but broken!) web.config every time, although it appears to be identical to the last.

    Any ideas? Paul.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of nickrita
    nickrita
    Participant

    @nickrita

    Paul, did you set the permalink-structure in the options? You have to set it first, before you do anything else, otherwise, the posts are not found.

    You even have to set ist if you want to use the default one.

    Avatar of joescars
    joescars
    Member

    @joescars

    Hey Paul, I am getting the same exact issue. Did you ever find a solution? I tried resetting the permalink structure as Nick recommended but it did not work for me.

    Thanks!

    -Joe

    Avatar of paul1664
    paul1664
    Member

    @paul1664

    Hey Joe,

    Not yet – hopefully get a bit more time on it tonight.

    It’s kinda lonely here on IIS!

    Paul.

    Avatar of joescars
    joescars
    Member

    @joescars

    Man! what a bummer!

    Avatar of joescars
    joescars
    Member

    @joescars

    I fixed it!! Woohoo!!! After much research I found similar issues with IIS 6 and the handling of redirects. I was lead to this page: http://ikailo.com/94/url-modrewrite-workaround-iis-60/ which has a fix for IIS6.. Well, with some tweaking and some magic I was able to come up with a fix for IIS7. it is as folows:

    1. Create a new file called 404-handler.php and put the code found here: http://ikailo.com/94/url-modrewrite-workaround-iis-60/ in it.

    2. You have to now configure your IIS7 installation (in my case IIS 7.5) to allow for custom redirects and to use this page for 404 errors. To do this you have to do the following:

    a) Open up IIS configuration manager (separate install for iis 7, included with iis 7.5).

    b) Browse to system.webServer/httpErrors

    c) unlock defaultPath

    d) unlock allowAbsolutePathsWhenDelegated

    e) set allowAbsolutePathsWhenDelegated to TRUE

    f) go to Error Pages

    g) right click on 404 and click edit

    h) select “Execute a url on this site” and set to /404-handler.php, hit ok

    i) right click 404 and select Edit Feature Settings

    j) set to custom error pages and path to /404-handler.php and path type to execute url

    I then had to reset IIS and IT WORKS!!! Woohoo!! I hope this helps others!!

    Joe

    http://www.561Media.com

    Avatar of paul1664
    paul1664
    Member

    @paul1664

    Hi Joe,

    I haven’t had chance to test this yet, but if it works then YOU ARE A LEGEND!

    Thanks! Paul.

    I am having the same issue.

    However, I am not using IIS. I am running Apache on a Windows server (a WAMP server).

    Is there somewhere else I need to change configuration settings in this type of setup?

    I have already tried resetting the permalinks and then activating BuddyPress to no avail.

    Thanks for any help you can provide.

    Rich

    Avatar of Steve
    Steve
    Participant

    @steveattwell

    I had the same issue running XAMPP on Windows 7 Prof and fixed it by adding the sub directory where my wordpress was located to the RewriteBase in the .htaccess file

    In my example I installed wordpress in a subdirectory called wp1
    To update .htaccess

    1. Open .htaccess file
    2. modify RewriteBase / to RewriteBase /wp1

    Avatar of jianchung
    jianchung
    Member

    @jianchung

    Hi @joescars, did you put the ’404-handler.php’ in your root folder or in your themes folder? I tried putting it in my root folder but on creation of Groups it redirects back to my homepage.

    Avatar of gravelhunter
    gravelhunter
    Member

    @gravelhunter

    this might help you

    Hi, I am still having problem with broken links on IIS 7.0, WP 3.0.3, BP 1.2.6.
    Specially activity, group creation and profile edit.
    When I use debug = true the pages load normally.
    I tried everything above.
    Anyone could help me with any new information?

    Avatar of joseffb
    joseffb
    Member

    @joseffb

    Had same issue with WAMP, you have to make sure your apache rewrite module is activated.

    Avatar of waldis
    waldis
    Member

    @waldis

    Joseffb, please read the posts.

    The very first post says “I have installed WPMU & BP on my server (IIS7, latest PHP & MySql) and everything works great on the first site.”
    The very last (right before your post) post says “Hi, I am still having problem with broken links on IIS 7.0, WP 3.0.3, BP 1.2.6.”

    And I’m sure you “Had the same issue.” The only trouble is you are not running IIS…

    i have the same problem with wamp on my xp server the rewritebase in .htaccess is alredy turned on en set to the right pad. please help me i want my site as fast as possible online

    now its dowing verry weard it shows no content on the pages but the rule works
    screenshot: http://i43.tinypic.com/14cw45v.jpg

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.