Skip to:
Content
Pages
Categories
Search
Top
Bottom

TinyMCE for BuddyPress – works for 1.2 as well

Viewing 23 replies - 1 through 23 (of 23 total)
  • Avatar of schwooba
    schwooba
    Participant

    @schwooba

    Yep. I’m having problems. I’m running WPMU 2.9.1.1 and BP 1.2. In the group section, when I have TinyMCE enabled and I enter some text, I get this error “Please enter some content to post.” Any ideas?

    Avatar of Enrico
    Enrico
    Participant

    @sulley

    Same for me. Plugin installed and enabled and getting “Please enter some content to post” error.

    WP 2.9.2 / BP 1.2

    Avatar of featherodd
    featherodd
    Participant

    @featherodd

    ditto

    Avatar of schwooba
    schwooba
    Participant

    @schwooba

    same thing here.

    Avatar of schwooba
    schwooba
    Participant

    @schwooba

    Did anyone get this to work? I get an error “Please enter some content to post.” Using WPMU 2.9.1 and BP1.2 final.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Hi everyone. I think this is an issue with the JS in the new bp-default theme. I’ll have a look at it in the next week or so and post an update to the plugin.

    Avatar of schwooba
    schwooba
    Participant

    @schwooba

    Great…thanks.

    Avatar of roydeanjr
    roydeanjr
    Participant

    @roydeanjr

    Still having this problem. Any resolution?

    I looked at the suggested link (http://teleogistic.net/2009/12/tinymce-in-buddypress/) but got no help and the last post is end of Jan?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I’m swamped with other work, sorry. If anyone picks apart and figures out the problem, please let me know. Otherwise I will try to fix it as soon as I can.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I took ten minutes and figured out why it’s not posting on the new bp-default. This zip file http://teleogistic.net/wp-content/uploads/2010/02/bp-tinymce.zip contains a version of the plugin that *should* work on 1.2+ versions of bp-default. I have not tested it thoroughly, and will not do so for a few weeks (at which point I will update the version in the repository), but until then please feel free to hack away at this one.

    Avatar of Anointed
    Anointed
    Participant

    @anointed

    worked for me, no issues to report.

    thank you!

    Avatar of Enrico
    Enrico
    Participant

    @sulley

    There are some issues:

    missing description of buttons

    /br doesn’t work

    lists don’t work

    Will wait for the fixes. Thanks ;)

    Avatar of Jalien
    jalien
    Participant

    @jalien

    works again, but the input boxes aren’t cleared after posting the update.

    wpmu 2.9.2 and buddypress 1.2.1

    Avatar of shazril
    shazril
    Participant

    @shazril

    There are some issues:

    missing description of buttons

    /br doesn’t work

    lists don’t work

    Will wait for the fixes. Thanks ;)

    you need to change wp-includes/js/tinymce/langs/wp-langs-en.js to en.js (i did duplicate the wp-langs-en.js then rename one of them to en.js).

    good luck.

    Avatar of thecorkboard
    thecorkboard
    Participant

    @thecorkboard

    wp: 3.0a

    bp: 1.2.1

    plugin: 0.3 bleeding

    links do not work – just link back to main directory

    everything else works, just needs CSS styling.

    request: add specific bp-tinymce classes to the elements you enable in TinyMCE

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Thanks for the feedback, everyone, keep it coming. Won’t have time to look seriously at this plugin for another few weeks, but it will be nice to have a list of tasks and requests.

    Hello I am currently running WordPress 2.9.2 and Buddypress 1.2.1

    I have this plugin installed on a test site that I have and from what I can tell, tinymce shows up on the content boxes on activity pages, profile pages, forums (starting a new topic) as well as replying to a forum post. However while on the forum pages once you input some content and press post, everything works fine (minus styling to the blockquote element), even though tinymce shows up in other areas once you hit “post” you get an error saying “Please enter some content to post”.

    I have tried this in Firefox 3.6, Chrome 4.1.249.1042 and IE7 so far and while Chrome and IE7 always give you the error when trying to post from any area other than the forums, Firefox will give you the error but if you refresh the page and press post again the content will post.

    Would seem like to plugin does just what you want in terms of the forums area and would be fine for me if I could disable it in the other areas unless there is a fix or workaround for the other areas.

    In any event thank you and good luck to those who can fix this.

    Avatar of mgpix
    mgpix
    Participant

    @mgpix

    Hi,

    I just tested the modified plugin on a classical WP install 2.9.2 with a bp-default child theme. Seems to work just fine.

    Thanks !

    I am currently running WordPress 2.9.2 and Buddypress 1.2.3

    modified plugin – all working fine

    http://www.barganews.com

    It’s making my head hurt on WP 3.0.

    I THOUGHT it was working, but it puts in the html as b and i instead of strong and em, which doesn’t work for some reason. Oh and it doesn’t refresh and wipe out the entry field.

    Okay, B and I were being stripped by my parent theme. Fixed that! :)

    Still having the problem where it won’t refresh and clear out the entry field, though.

    Avatar of vishmoon
    vishmoon
    Member

    @vishmoon

    Any solution to the
    tag not taken by firefox in latest plugin modificaiton with WordPress 2.9.2 and Buddypress 1.2.3?

    Avatar of Narada Das
    Narada Das
    Participant

    @oneearth

    Hey any movement on this in last few months? I just made another post here about the need for tinymce in BP profiles http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/html-on-profile-page-can-it-be-done/#post-77788

Viewing 23 replies - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.