Skip to:

404 Page Not Found Issues – Mod Rewrite

  • zooney


    This is just an FYI that may help some people out with a minor headache that took me a few minutes to sort out. I’ve seen other posts in these forums about it, but they’ve since been closed, so I couldn’t respond directly.

    Every page (except the homepage) on my BuddyPress install returned a 404 Page not found error…

    …the reason?

    I was too stupid to realize I should probably enable AllowOverride All so that mod_rewrite could, like, do something.

    I’m not sure if it’d help people out if BuddyPress did a “Clean Urls” check or something similar since mod_rewrite is required for it to work, it seems. It might help people through a headache like this.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thanks for the feedback zooney, that’s a useful tip.

    Andrea Rennick


    Possibly it might help to do a check, but during install people are urged to make sure their WPMU install works. The issue you described above woudl have been immediately apparent without BP. The main blogs’ post permalink’s woudl not have worked.

    And despite how many warning given, people still miss it. (like the big huge wall of text on the MU install screen)



    Ahh now I understand what the problem is. many thanks for that. My WordPress Mu wasnt actually working in first place, and had nothing to do with BuddyPress.

    However the question is; can I – being hosted by GoDaddy Windows Economy – access the config file of the webserver in order to make this little change? :(

    Many Thanks for help,




    OK, I might be suffering from this if I knew what “this” was. My MU homepage works fine. When I go to the blog (there’s only one for now) homepage it gives me header/footer/sidebar, but 404 where the body should be.

    In the sidebar, I can click on my about page and other pages I’ve added which show up with the mod-rewrite rule I made in admin. On the main homepage screen, I can click on the links for posts and the show up fine.

    It’s only the blog homepage that I get these errors. My setup is a bit funny.

    Root directory has 2 files wp-config and htaccess and 2 folders /core and /wp-content. The blog homepage is pointing to /core whereas the site homepage is correctly root. I’m still testing on XAMPP for windows.

    Yes I did ask on MU forums, but since it came up here, I’d thought I’d ask.



    i m also having the same problem and yet not solved cah anyone help me.

    I have installed WordPressmu 2.8.6 and its workin fine all alone now after installing plugin Buddypress 1.1.3 and changing the themes by moving the bp-themes to wp-content/themes except the home page rest all other links are showing…

    The requested URL /wordpressmu/linkname(say blog or member) was not found on this server.

    404 not found…

    What to do?

    Plz HElp

    @rahulukil you’ve made your own thread, please don’t cross-post. You might not be having the same issue as this poster.



    Ok, I THINK I have the same problem. My MU installation was ok, but when I try to create a topic in a forum I get a “Page not found” error. I’m racking my brain to fix this. PLEASE HELP



    Is this the same problem I’m having here?

    Not trying to hijack this thread, but I think it is…



    solved my issue. Hope it helps someone.



    Ran into the same issue of 404 Not Found after activating BuddyPress on my WP installation on Ubuntu 9.10. Looks like the default Apache installation didn’t have mod_rewrite enabled.

    To address this I did the following:

    – sudo a3enmod rewrite

    – sudo apache2ctl restart

    – put .htaccess in my WordPress directory (/var/www) :

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]


    # END WordPress

    – put the following in /etc/apache2/apache2.conf

    DocumentRoot /var/www

    <Directory />

    Options FollowSymLinks

    AllowOverride all


    <Directory /var/www/>

    Options Indexes FollowSymLinks MultiViews

    AllowOverride FileInfo Options

    Order allow,deny

    allow from all


    I haven’t tested to see if this is all needed or not, but that’s what my site has configured now and it appears to fix the issue.



    This definitely should be in the installation notes.

    This is what worked for me:

    <VirtualHost *:80>

    DocumentRoot /var/www/html

    <Directory “/var/www/html”>
    AllowOverride All


    Definitely needed explanation for a beginner.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘404 Page Not Found Issues – Mod Rewrite’ is closed to new replies.
Skip to toolbar