Skip to:

Avatar Upload Issues

  • John James Jacoby


    There are numerous tickets in the trac and topics in the forums popping up. It seems lots of users are having issues uploading avatars with 1.1.2.

    I’ve tested this on two different environments with subdomains and subdirectory installs and cannot duplicate the problem myself. However, we’re aware that it’s an issue and will keep trying to resolve it.

    In the meantime, please route your avatar upload related discussion here. It will help us better monitor everyone’s experiences. Other topics regarding this issue will be locked and linked to this topic until it is resolved.

    Thanks everyone for being awesome and patient and understanding. :thumbup:

Viewing 11 replies - 101 through 111 (of 111 total)

  • Treisee


    I had a new fresh install of WordPress 2.9.2 and Buddypress Version 1.2.3 all working together fine, then I added a plugin, WP Featured Content Slider Version 1.0 and thats when I had an issue with cropping members avatars and group avatars.

    The image would upload but the cropping window wouldn’t appear, just two copies of the image one the upload size and one a cropped size would show.

    After deactivating the new plugin, the cropping function worked normally again.



    “The image would upload but the cropping window wouldn’t appear, just two copies of the image one the upload size and one a cropped size would show”

    This is what I am experiencing, but I don’t know if a plugin is creating the problem.

    GnG Team


    I have that same problem with WP Featured Content Slider and Buddypress… has anyone figured out how to fix this as I really need the slider!



    Don’t know if this was anyone else’s issue, but this was my problem and the solution I found.

    PROBLEM: jcrop function wouldn’t work after an avatar was uploaded either on the registration or edit avatar pages within buddypress. The image and thumbnail would show, but there was no crop box to change what was selected for the thumbnail. Very frustrating.

    SOLUTION: stupidly simple once I finally found it – for some reason there was no link to the external jcrop javascript file appearing in the header of the pages! (This can be checked by viewing the page source of the problem pages via your browser) To fix this I edited the bp-core-cssjs.php file which is inside the bp-core folder inside buddypress. Right after this line:

    `$aspect_ratio = (int) constant( ‘BP_AVATAR_FULL_WIDTH’ ) / (int) constant( ‘BP_AVATAR_FULL_HEIGHT’ ); ?>`

    I added:

    `<script src="/wp-includes/js/jcrop/jquery.Jcrop.js”>`

    And now the crop tool is showing up and everything works perfectly! :) Note that you may need to change the path to the Jcrop.js file depending on your site setup. Before this I had also downloaded the latest version of jcrop from and updated it on my site, so I don’t know if that plays in at all or not.

    Anyway, don’t know if that helps anyone else, but it did the trick for me so I figured I’d share it just in case.

    WP – 3.0.1
    BuddyPress –
    Buddypress theme with compatibility
    Ok.. I want to make clear the problem I have been having with my Avatar Cropping process in my BuddyPress installations.
    I can crop successfully on my dashboard, Using the “User-Avatar” plugin. But then I installed buddypress and when users attempt to build their own avatars inside the themed site, the only thing I get is a cropped preview of the top left corner of any picture I choose(both pictures display properly), but no ability to crop or even see the cropping elements.
    I have read thru the solutions, and tried to implement them. First.. I use “qian-ava”s solution. I am using WP 3.0… so I need to find my Upload paths by going to..
    When there I add to the Uploading Files fields by entering “wp-content/uploads” into the” Store uploads in this folder” area and my full path of into the “Full URL path to files” area. Just note… I added all the double quotations.
    After I do this I attempt to go into line 389 of my bp-core-avatars.php file and…
    if ( !$path = get_option( ‘upload_path’ ) )
    $path = WP_CONTENT_DIR . ‘/uploads’;
    if ( !$path = get_option( ‘upload_path’ ) )
    $path = WP_CONTENT_DIR . ‘/uploads’;
    else $path = ABSPATH . $path;’
    But… I do not have the “if” statement to replace! The closest thing I have is from 384 – 390…
    ‘if ( empty( $bp->avatar_admin->resized ) )
    $bp->avatar_admin->image->dir = str_replace( BP_AVATAR_UPLOAD_PATH, ”, $bp->avatar_admin->original );
    else {
    $bp->avatar_admin->image->dir = str_replace( BP_AVATAR_UPLOAD_PATH, ”, $bp->avatar_admin->resized );
    @unlink( $bp->avatar_admin->original );

    But I don’t see anything that I can replace. So either way.. I tried to test the script and just pop it in nearest to the line 389 to no avail. I ended up getting an error and my page does not load. Back to the drawing board. I reversed the process and started again.

    I then took “Creay”s advise (, because his problem directly describes mine, and decided to look into the expression of Jcrop and its possibility of not firing off. He changed core-cssjs.php inside the pb-core folder inside the buddypress plugin. He added
    ‘<script src="/wp-includes/js/jcrop/jquery.Jcrop.js”>’
    After the line ‘$aspect_ratio = (int) constant( ‘BP_AVATAR_FULL_WIDTH’ ) / (int) constant( ‘BP_AVATAR_FULL_HEIGHT’ ); ?>’

    I have a area in my bo-core-cssjs.php file that reads between line 88-91
    ‘ // Calculate Aspect Ratio
    if ( (int) constant( ‘BP_AVATAR_FULL_HEIGHT’ ) && ( (int) constant( ‘BP_AVATAR_FULL_WIDTH’ ) != (int) constant( ‘BP_AVATAR_FULL_HEIGHT’ ) ) )
    $aspect_ratio = (int) constant( ‘BP_AVATAR_FULL_WIDTH’ ) / (int) constant( ‘BP_AVATAR_FULL_HEIGHT’ );
    ?> “
    So after the ?> I added the line. Nothing. Still not getting the crop to work properly. I encourage anyone to take a try and register on the site.. I would like to nail this problem down before I launch the site or even more to far forward. The site is
    Thank you for all your help in advance.



    I’ve tried reading through all the above posts, but my eyes started to bleed. Nothing looks like what I’m experiencing, so I’m hoping maybe someone can confirm that and help me find a solution.

    When I upload a group avatar to BP on WP 3.1 (no multi-site) running on RHEL, I can see the file upload to /var/www/html/wp-content/uploads/group-avatars/4 . However, when I do the crop and save action, the file disappears from the directory. The permissions are set at 777 with apache:apache ownership, so I don’t know how much more open it could be. Something is removing the image at crop time.

    Any ideas?



    Concerning the avatars not uploading part, here is what worked for me.
    I run WP 3.1.1 with BP 1.2.8 and I was not able to upload an avatar. After setting the correct permissions, the upload process created an empty directory – no image was uploaded and accordingly, the avatar didn’t change.
    I searched and read posts for hours until I figured that I was missing the GD library of PHP. One figures this out by putting “ in a file on their server and going to the corresponding address (i.e. – phpinfo.php being the file you just created). If GD is not listed at all or GD Support is listed as disabled, then you need PHP with GD. If you run the server, that would be done by installing php5-gd (e.g., `sudo apt-get install php5-gd`).
    Hope this helps someone.

    I’ve read through all the help forums and still have not fixed the problem. My avatars show up, but I cannot crop them. This was working when i first set the site up then once I moved the site to a new URL it stopped working. i moved from to any idea what I should look into? I havent made any changes to the site that would casue the issues. I even tried deactivating then activating all the plugins and still nothing. Any help would be appreacited!

    I don’t know if this is where I need to be posting this. i’m having two issues with the avatar page in registration.

    1. when I upload and crop an avatar, it doesn’t “take”; I end up with the default (mystery man) avatar. But I can re-upload and crop via MyProfile>ChangeAvatar, and the avatar then is saved. Not sure, after skimming all posts in this discussion, how to deal with this.

    2. more importantly to me, from a user standpoint, is the lack of direction from the avatar page. When first arriving, I’m told “we’ve fetched an avatar for your new account…” but there’s no means of actually accepting that avatar. My only options are “Choose File” and “Upload Image”. As a user, I am FORCED to upload an image (which, from #1, is then lost anyway). If I do upload an image, I am then returned to the same avatar page with the default (mystery man) avatar and the same two options (Choose File and Upload Image).

    Some help establishing a simple “accept this avatar” button would be appreciated.

    I’m using most current BuddyPress 1.2.8 with WP3.1.2.


    This thread is over a year and a half old. Please create a new topic for new problems.

Viewing 11 replies - 101 through 111 (of 111 total)
  • The topic ‘Avatar Upload Issues’ is closed to new replies.
Skip to toolbar