Skip to:

Avatar uploading to wrong folder

Viewing 8 replies - 1 through 8 (of 8 total)

  • @mercime




    My apologies:

    Site is located at

    – WordPress 2.9.2 (standalone version) on a subdirectory – New installation

    – Buddypress 1.2.3 installed – New installation

    – Using a ‘buddypack’ theme (customized for my needs)

    OTHER Plugins: Wishlist Membership software

    I have done no core customizations or touched the Buddypress files in any way. I installed WordPress, I installed the Buddypress plugin and then chose a compatible theme (which as you can see I customized. I then installed Wishlist Member.

    I realized that I couldn’t upload an avatar of myself and then checked with my host that my configuration was compatible.

    Is that everything you need to know?

    There’s been a few of these unusual picture URL paths going around lately on some installs. Not sure of definite fix. I am thinking it may be to do with Apache HTTPD installs using the cgi-bin method rather than loading the Apache extension directly, but I have no evidence or testing to prove this. Anyway.

    Have a play with: Settings > Miscelleanous in your WP Admin. Try setting “Full URL path to files” to and see if that makes a difference. Remember to turn off any page caching you have whilst testing.



    No, this does not make a difference. Is there any other way to tell WordPress where to upload (anywhere in the Buddypress configuration?



    Paul, thank you for your great suggestions. It is magically working!

    I went back to my host and explained that the images were uploading to the wrong folder and what was their opinion about what you suggested about Apache installs… and either they fixed it (because it suddenly works) or my browser cache wasn’t showing the change you suggested to the upload folder in ‘Miscellaneous’.

    I am not questioning fate (it is most likely the suggestion you gave to map the ‘Full URL path to files’ suggestion. I appreciate your help and am impressed with this support forum and how my problem was responded to so quickly!

    Yay for magic! :D

    For anyone else Googling this in the future, we do have a bug ticket about this issue —



    Hi Paul, I trust you have fully recovered from Kilkenny by now.

    You mention in trac that you’re not getting much technical detail about each install; as it happens, this problem has cropped up on a BP install on my purely-experimental, not-at-all-production, mucking-about server, you would be very welcome to ssh in as root or login to WHM – EasyApache makes it pretty easy to see what is and is not installed.

    I also have that new ServerBuddy server analysis plugin installed, lists various settings and permissions in a pleasing enough manner.

    The site where this crops up for me is:

    … and, just to be clear, it isn’t a problem for me, this install will be getting wiped anyway, I just thought it might be an interesting and accessible example of the problem in the wild.

    So, what’s happening is that the image URLs are missing the “wp-content/” part:

    Images are appearing in pages as, for instance,

    … when, of course, they should be

    This is BP 1.2.3 on an MS WP 3.0b1, so, there is no Settings > Miscellaneous to attempt the Full URL path magic trick you suggested above but it is a pretty clean, recently installed CentOS + WHM box, standards settings, it might be useful in figuring out why the paths are getting mangled.

    Again, this a purely experimental site and server, I didn’t actually expect to get BP working properly on a beta WP anyway, don’t worry about breaking anything, just let me know if you think it might be useful and want me to send you the passwords.

    John James Jacoby


    As an update, I’m working on fixing this for all installs this week.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Avatar uploading to wrong folder’ is closed to new replies.
Skip to toolbar