Skip to:

BuddyPress 1.1.3 Installation Fail in bp-activity.php

  • carinallc


    I am running the latest WPMU version, and deactivated all plugin prior to the upgrade. The upgrade appeared to go successfully. However, on the activation I get a Fatal Error in the bp-activity.php file on line 52.

    Cannot redeclare bp_activity_install() (previously declared in …plugins/buddypress/bp-activity.php:19 in ../plugins/buddypress/bp-activity.php on line 52

    Can I just copy back my previous buddypress plugin folder?

Viewing 23 replies - 1 through 23 (of 23 total)

  • Meerblickzimmer


    Get the same and my “workaround” are (because i get a white-screen on /wp-admin):

    – rename buddypress-folder under /plugins

    – login on wp-admin

    – go to “Plugins” and the buddypress-plugin deactivated automatic

    – rename buddypress-folder under /plugins to the old one

    – activate the plugin

    And all works fine now.

    Maybe it helps.

    Greetings. M

    Brajesh Singh


    Well,I had seen this issue so many times,so I experimented.

    If your plugin is activated sitewide(which is almost true in case of buddypress) ,It is going to give you at least one such error(try with other sitewide activated plugins by upgrading them).

    So this is not an issue with the buddypress but the problem is with the updating/activation of site wide activated plugins in wpmu as far as I see.

    Easy work around(if you don’t want to see this problem)

    1.Login to dashboard

    2.deactivate buddypress

    3.upgrade buddypress

    4.Activate again

    You will never find this problem again.



    Thanks for the replies. I did as you both suggested:

    Deactivated ALL plugins

    Renamed the BuddyPress folder old_buddypress

    Copied back my prior BuddyPress folder

    Ran the upgrade (which was successful)

    Activated BuddyPress

    Got the same error message. All other plugins are still deactivated.

    Running WPMU 2.8.6

    Brajesh Singh


    is buddypress 1.1.3 or any prior version is in mu-plugins dir.

    It will be better ,if you can post the complete error.

    like unable to declare in /home/myaccount/whatever/wp-content/plugin/bp-activity style.



    Ok, this is weird.

    1. Even though the activatio failed, I see the BuddyPress admin section in the left-column of wp-admin (General Settings, Component Setup, etc.)

    2. I have (2) BuddyPress plugins listed. One was showing as Active, the other as Deactivated. I deactivated the one that was showing as Active.

    Now, I have (2) BuddyPress plugins listed, both deactivated. Not sure how this happened. What should I do?



    Fatal error: Cannot redeclare bp_activity_install() (previously declared in /home/content/66/4913966/html/wp-content/plugins/buddypress/bp-activity.php:19) in /home/content/66/4913966/html/wp-content/plugins/buddypress/bp-activity.php on line 52

    Brajesh Singh


    this is not a problem.

    Please remove/delete the older one (you had renamed) and go again to plugins.activate the new one.

    btw ,there will be a small information saying buddypress v 1.1.3 on the plugins page,you may look for that

    Edit:This is my reply for your previous post about redundancy,I just found your new post too.



    Ok, I deleted both of the listed BuddyPress plugins and restored by backup of the v1.1.3 upgrade. The activation went fine, and the site is up and functioning.


    Glad I had a backup, but still mystified as to what happened.

    Thanks everyone!

    There’s always the sledgehammer approach… go into the database in delete the value for the key “active_sitewide_plugins” in the “wp_sitemeta” table.

    Brajesh Singh


    ok,here are my thoughts and I will like to go into more details,so would love to hear from everyone of you who has / or is facing this issue.

    1.De activate buddypress/buddypress dependent plugin

    2.Upgrade buddypress

    3.activate it sitewide .

    I hope,if you de activated it before upgrading,activation will not generate error,as I have tried on 3 different installs,and I believe the root cause of the error is the sitewide activated plugin upgrade mechanism.

    So,It will help everyone ,if the people who go through this ,post their experiences here.May be it can help in investigating further the causes.

    The problems are all related to this bug:

    Yup. Deactivate. Update. Activate. The problem occurs when you don’t do that. I made that mistake myself. I took the “sledgehammer” approach. Went into the DB and deleted the value for “active_sitewide_plugins”. Worked for me.



    Fatal error: Cannot redeclare bp_activity_install() (previously declared in /home/garysmit/public_html/wp-content/plugins/buddypress/bp-activity.php:19) in /home/garysmit/public_html/wp-content/plugins/buddypress/bp-activity.php on line 52

    same here…but I took the time to deactivate BP first and all (I don’t have many) plugins too. I deactivated them all. Then I hit upgrade automatically. Got the above error.




    Same error as gsmith above. Very new WPMU / Buddypress install, so BP was the only active plugin. Deactivated it. Upgraded Automatically. Got the error.

    Then when in an manually updated, overwriting the still deactivated plugin with 1.1.3. Same error again.

    Can someone break down this sledgehammer method in a bit more detail?



    Ok. Now I’ve really screwed things up. I thought I could take the advice of Meerblickzimmer and go in to the Plugins folder and rename the buddypress folder (even though it was deactivated already, I thought I could install fresh again and see if that helped.

    Now I get this error on an otherwise white screen sitewide:

    Fatal error: Class ‘BP_Groups_Group’ not found in /home/litcirc/public_html/wp-content/plugins/bp-group-calendar/bp-group-calendar.php on line 129

    Even thought that calendar plugin wasn’t active in the first place. I tried to backtrack by renaming the buddypress folder back to what it was, but the damage is done somehow.

    My “sledgehammer” option assumes you have access to your Database… most likely via PHPMyAdmin. Look for a databases option in your web host control panel. Open the database for your site and look for the wp_sitemeta table near the bottom of the list of tables on the left. Open that table. Then click on the “browse” tab to see the contents of that table. Now look for the “active_sitewide_plugins” row (in the meta_key column). Edit that sucker. Just click on the little pencil. And simply delete the junk that is stored in the “meta_key_value”. This worked for me. But please bear in mind… you’re messing directly with the database! And you do so at your own risk. But again… this worked for me. And it should be pretty safe. Just don’t go editing or deleting other things in there willy-nilly. You could bust the entire site pretty easily.

    Maybe make a backup before you start. Right when you open the database… click the “export” tab.



    I had the same problem, but I followed Davids advice and did this:

    All plug-ins are disabled and I have a backup of my db too.

    Went to phpmyadmin and in the table wp_sitemeta removed the values by clicking on the edit button from the 3 columns.




    Then went to cpanel>mysqldatabases and repaired the database

    Then went into my file manager (my site always has issues with cache) and removed any of the long cache folders in wp_content/cache

    Went back to my dashboard, left the plugins menu and went back into it and enabled buddypress. Then enabled all the other plugins.

    Some the steps I’m sure aren’t needed but it worked for me.

    Ted Mann


    I had more or less the same problem. Tried the auto-update. Error. Tried overwriting the files. Error. finally deleted the BP plugin, reinstalled, and am now back in business.






    This problem occurred even though I had desactivated all plugins (including BP) before upgrading. And the Buddypress menu showed in the admin menu though I had not yet been able to reactivate BP due to the bp-activity error.

    Like David Lewis, deleting the “active_sitewide_plugins” value in the wp_sitemeta table sorted it out.



    Did the same as David Lewis – cleared the meta_value form the record in wp_sitemeta with ‘active_sitewide_plugin’ as meta_key, and it worked. Not sure what thestasi is on about.

    Now, I don’t want to sound ungrateful, but… shouldn’t you guys check these things before you release them? Mine was a fresh MU install and a fresh BuddyPress install. I am test-driving BuddyPress for a possible client, the fact it doesn’t even install correctly it’s not encouraging.

    Thanks anyway.

    @fritzthecat As per Andy Peatling’s comment above, this appears to be a bug with the current version of WPMU, not BuddyPress.

    John James Jacoby


    There’s a fix for this “brute force” method of plugin deactivation in the trunk of WPMU2.9, so a fix is on the way if you don’t have phpMyAdmin access.

Viewing 23 replies - 1 through 23 (of 23 total)
  • The topic ‘BuddyPress 1.1.3 Installation Fail in bp-activity.php’ is closed to new replies.
Skip to toolbar