Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress 7.1.0

Viewing 10 replies - 1 through 10 (of 10 total)

  • djsteveb
    Participant

    @djsteveb

    The edit avatar / upload profile pic is still broken for new installs.

    my older bp sites (that have been updated to latest BP) (one multiSite and one singleSite) still have ‘change profile photo’ via the top right bar menu under profile.. and on the profile page itself.

    A newer BP install 5 months ago, bp 6.3 and a fresh install this week (7.1) – do not have the option to edit profile pic / avatar.

    Even when switching to default theme and turn off all other plugins.

    Change cover image does still appear – and I double checked the bp settings are check for : Allow registered members to upload avatars”

    Any ideas what is happening here?

    Hi @djsteveb

    I understand you might be disappointed to have troubles with the avatar feature, but this trouble is not a generic one, it’s specific to your WordPress configuration. Saying the following is very wrong:

    The edit avatar / upload profile pic is still broken for new installs.

    I can confirm everything works as expected.

    Since BuddyPress 6.0, users can manage their local avatars (hosted on the community website) whether or not the xProfile component is active. See this developer note for more information about the changes we made in 6.0.

    Below is a screenshot I just made having the xProfile component active :

    avatar-xProfile on

    Below is another screenshot I just made having the xProfile component inactive :

    avatar-xProfile off

    To control whether or not to allow users to manage their avatars from their profile page, as you said you can use the BP option about “Profile Photo Uploads”. Below is a screenshot of the BuddyPress options screen (Settings > BuddyPress).

    BP Options screen

    If you uncheck “Profile Photo Uploads”, then users can’t manage their locally hosted avatars.

    And there’s also a WordPress setting you need to pay attention to. If you decide that Avatars shouldn’t be shown globally on your WordPress site, then users cannot manage their local avatars from the front end. This WordPress setting is available from the Discussion settings screen (Settings > Discussion). See the screenshot below :

    WP Discusion settings

    For instance, if you uncheck the “Avatar display” WP setting, then the page to manage avatars is not available even if “the Profile Photo Uploads” BP Option is checked. Here’s a screenshot below showing how a user’s profile page looks like when you globally disable Avatars in WordPress.

    Avatars globally disabled

    The page to manage user’s avatar is not available and the user’s profile header does not include the avatar.

    Again, I confirm everything works as expected in BuddyPress, the issue you’re mentioning is specific to the way you configured WordPress &/or BuddyPress.


    dotMastaz
    Participant

    @dotmastaz

    Eh bien merci beaucoup pour ce fix !


    litbyu
    Participant

    @litbyu

    I’m having a problem with profile photos also as well as cover images. When clicking on “Change Profile Photo”, I get this: /*Upload/*]]>*//*Take Photo/*]]>*//*. This is not visible when clicking on “Change Cover Image”. As a matter of fact, it does nothing when “Select Your File” button is clicked. Anyone have any ideas for how I can get these to work?

    @litbyu I believe you have an active plugin that is minimizing JavaScript templates instead of only minimizing JavaScript scripts.


    litbyu
    Participant

    @litbyu

    I have uninstalled each plugin then checked my site (one at a time) but still have the problem. Should I uninstall every plugin and add them back one at a time to determine which one it is or would what I have already done identified the culprit?


    Mathieu Viet
    Moderator

    @imath

    Do you have a drop in or a a must use plugin to cache your site ? It’s usually cache plugins that might do some JS minification.


    litbyu
    Participant

    @litbyu

    That’s exactly what it was so I deactivated it. Can I leave it deactivated or am I risking my website’s safety doing so?


    Mathieu Viet
    Moderator

    @imath

    There should be an option into the Plugin’s settings or a filter into the Plugin’s code to disable **inline JavaScript minification**. I’m unsure it’s about security, I believe it’s more about performance.


    litbyu
    Participant

    @litbyu

    Got it. Thank you for your help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
Skip to toolbar