Skip to:

Buddypress forums not working

  • christofian


    just installed buddypress, and everything is working fine accept for the forums, which are impossible to use because of three problems.

    One: every time I post a topic I get an error message: “There was an error when creating the topic”.
    Two: whenever I view the forum index, it says that there arn’t any topics, but after clicking on the “order by” menu for a bit, the topics appear.
    Three: it always says that there are no posts whenever I view a topic, even though there are. When it says that, there is no form to add any new posts.

    What is causing these three problems? I am running wordpress 3.0.1 and buddypress Help is appreciated. Thank you.

Viewing 21 replies - 1 through 21 (of 21 total)

  • christofian


    bump. Please help

    Boone Gorges


    We’ll need more information in order to help.

    Also please do not bump your posts more than once a day. This board is not sufficiently well trafficked to expect a response within a few hours.




    1. Which version of WP/MU are you running?
    wordpress 3.0.1

    2. Did you install WP/MU as a directory or subdomain install?
    3. If a directory install, is it in root or in a subdirectory?
    the directory that I installed it in is:

    4. Did you upgraded from a previous version of WP/MU? If so, from which version?
    no, this is a clean install

    5. Was WP/MU functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.

    6. Which version of BP are you running?

    7. Did you upgraded from a previous version of BP? If so, from which version?

    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    Akismet, BuddyPress Moderation, and Register Plus. I tried deactivating them to no avail.

    9. Are you using the standard BuddyPress themes or customized themes?
    the standard bp theme with a different header image

    10. Have you modified the core files in any way?
    Yes. Before this I was getting an error because of mysql_get_server_info on, so I changed line 1589 (or somewhere around there from `return preg_replace( ‘/[^0-9.].*/’, ”, mysql_get_server_info( $this->dbh ));` to `return preg_replace( ‘/[^0-9.].*/’, ”, mysql_query(“select version() as $this->dbh”) );`, and that error stopped.

    11. Do you have any custom functions in bp-custom.php?

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    it came with bbpress build in.

    13. Please provide a list of any errors in your server’s log files.
    couldn’t find those: I will keep on looking though.

    14. Which company provides your hosting?

    15. Is your server running Windows, or if Linux; Apache, nginx or something else?
    linux with apache 2.0

    Thank you for your help.

    Thorsten :-)


    I’ve still a similar problem, see butte didn’t getany response yet. I use a windows 2003 Server System with the following plugins installed: Akismet, BP Xtra Signup, BuddyPress, BuddyPress Album+, BuddyPress Forums Extras – RSS Feeds, Buddypress Friends, BuddyPress Profile Privacy, BuddyPress Tweet Button, Configure SMTP, Duplicate Post, Easy Verification, Fast Secure Contact Form, Invite Anyone, Jet Event System for BuddyPress, Link Library, My Brand Login, NextGEN Gallery, oEmbed for BuddyPress, TinyMCE Advanced, Transposh Translation Filter, Welcome Pack, WP Google Weather



    I don’t think the problem is any of the plugins, but buddypress itself. I would file a bug, but I have no idea what is causing it. People, please give us a little bit of help here. This problem is driving us mad, and I have been searching on the forums and finding nothing.



    bump, with more info.

    I had followed up on a idea from searching the web, and that was I should “Go to: phpmyadmin > yourdatabase > wp_bp_groups_groupmeta and Find the group you’re attempting to post to and then delete the forum_id value.”

    The post is 8 months old, but I tried that, and the table and the forum id doesn’t exist. However, I looked around the database, and there was no reference between groups and forums on the database. What I mean is that in the tables that groups use and the tables that forums use, there is no reference to what group the forum or topic is in, and the group has no forum assigned to it. That’s the problem. There is no conection between groups and forums in the database.

    I tried deleting all of the tables that belong to buddypress and reinstaling buddypress, but the problem is the same. So what should I do? Is there some sort of super reinstal that I need to do? Or should I add a forum_id field to the group table? Please help me out here, I will be trying things and trying to get it work. I will post any results in this topic.



    some more info:

    I tried installing bbpress separately and linking that to buddypress. This time, the topics I post show up, but If I post them through buddypress, it says that there are zero posts in the topic (it doesn’t matter if I view them through buddypress or bbpress, it still says the same thing). what’s wrong?




    Boone Gorges


    It sounds like you didn’t run the bbPress setup installer, or that something went wrong during that setup process.

    Go to Dashboard > BuddyPress > Forum Setup, and click Setup a new bbPress installation. Re-install if it asks you to.

    If it still doesn’t work, check to make sure there’s a bb-config.php file in the root of your WordPress installation, and that the credentials in that file are correct.



    tried reinstalling it on the buddypress side: bb-config is in place and correct, but this time the topic and the post didn’t get posted. When I integrated it with an existing bbpress installation: I could read and post topics from buddypress: the problem was that while I could post topics, the post didn’t go through and it said that I had 0 posts in the topic.



    I have had the same or similar problem. No group forum posts.

    I just tried an experiment. I added a group, but made it completely PUBLIC.

    Then I created forum inside that group and added a post to that group’s forum.

    Wallah! The GROUP forums now has posts.

    Hope this helps.



    I tried making the group completely public and private: didn’t work.

    Hello, I have installed Buddypress 1.2.8 in wordpress 3.1, and solved the forum topic creation error buy adding an auto_increment field to the bb_term_relationships table, as follows:

    id bigint(20) auto_increment

    It seems that the installation does not create the table with a primary auto_increment id field, and for me that was causing the problems. I am running a windows xp with xampp, working in localhost. Mysql version is 5.5.8 and php 5.x. The theme I am using is a custom one, located at wp-content/themes/

    Still, I cannot see each topic’s detail page when I click them. I am trying to fix this at the moment, any clues ?



    1. Deactivate all plugins except BuddyPress.

    2. Change theme to bp-default.

    3. Install Forums – BuddyPress > Forums Setup > New Installation

    4. Run Settings > Permalinks

    5. Create new public Group and allow Forums

    6. Create a new Topic and publish.

    I have tried all that and if I don’t manually add an auto_increment id to the bb_term_relationships table, I get the error “There was an error creating forum topic”. I cannot either see the topic details… I have no additional plugins installed and my permalink structure is the “Month and name” one. Also, my document root is “c:/xampp/htdocs/” and I have my installation in “c:/xampp/htdocs/www/wordpress”.

    Ok, it seems I had some database problems. I have innodb as the default database type, so when creating the forum tables, there was an error by a “TYPE = MYISAM” sentence in a table. The result was that the bb_posts table didn’t create, and so I couldn’t see the posts. As an advise, always check that the bb_press tables have been correctly created, they are: bb_topics, bb_term_taxonomy, bb_term_relationships, bb_terms, bb_posts, bb_meta and bb_forums.

    Hope it helps someone.



    Can someone please explain to me where I can find the “bb_term_relationships table”? I am trying to follow how to fix this but I am lost… any help would be greatly appreciated.

    Just posted this for another guy. I actually read this forum when having my issue…just resolved, hope it works for you too. took about 10 mins with this technique, hope it works.
    1. First delete the bb-config.php from you server (in root wordpress folder, if you used the buddypress bbpress installer).
    2. download the zip of bbpress from their site. -> extract all -> and ftp to a new directory (foooorum was mine)
    3. go to it should open their installer.
    4. ftp your wp-config.php from your server to computer and open it.
    5. follow instructions on the installer first is db info: dbhost db user, user password. all this is in the wp-config.php file you just opened. Use this same info -> click advanced settings, and make sure the host is right mine needed to be changed from localhost to
    6. click to step two, click wordpress integration. Now you need to log onto you phpmyadmin. you can often do this by then use the login details for the db that you used again, the dbuser and user password. Once in there click the database, you will see a lot of files that look like wp_daks_bpetc This is important. you need the wp_daks (the daks signify random letters from your actual one). So just where it asks for the tables of wp files give it to them in “wp_daks_” format. click next, and install i think. ALMOST THERE!
    7. go to your wp dashboard click on the buddypress area, click on forums setup. it will say you already did it, but click reinstall.
    8. Select use an outside install.
    9. Enter the path of the other install for me it already said /user/domain/ so i just changed it to /user/domain/foooorum. Click complete and you are good to go. no it should all work. Please let me know if it doesn’t, cause it worked for me easily when nothing else would.



    @dcaccavo thanks for sharing. Is this for latest versions – WordPress 3.1.1, BuddyPress 1.2.8 and bbPress 1.0.3?

    The last time I did an external bbPress install for BP was more than a year ago and it took me about 38++ steps :-) If I recall well, that was bbPress 1.0.2 with WPMU 2.8.4a and BP 1.1.2 or something I think…

    How’s the external forum working so far for you? Does posting to forum show up in sitewide Activity Stream and in member’s activity stream?



    Here’s the 100% working solution!!! thanks to John

    1 – Delete your group.. doing the other way around is impossible for non-developers.

    2 – Create a the new group..
    STEP 1 add title and description ( title will be used as the group slug )
    STEP 2 ( DO NOT SAVE SETTING AS IS!! I REPEAT DO NOT!!!! ) here’s what to do.
    in step 2 ((un-check)) the Enable discussion forums, and then check it again.. and THEN save settings..
    Step 3 avatar bla bla.. but the thing is :) it’s solved!

    How it works!

    the problem is stupidly simple.. that in some times.. ( not all buddypress installations for some weird reason either plugin conflict or a script timing error…

    the check of enable forums is saved as “null” instead of 0/1 imagine it as a multiple choice radio button..

    as long as you didn’t either.. it’s unselected.. but once you click.. it’s always 1 of the both and can’t be null…

    Why is this happening? even WPMU and BPMU geniuses couldn’t solve it for 2 years now ^__^’>

    I had this problem and have finally solved it.

    Here’s what I did:

    1. deactivate all plugins except buddypress
    2. change theme to default
    3. backup your bb-config.php file
    4. delete bb-config.php
    5. backup /public_html/wp-content/plugins/buddypress/bp-forums
    6. rename /public_html/wp-content/plugins/buddypress/bp-forums
    7. download the latest version of Buddypress
    8. upload new version of /public_html/wp-content/plugins/buddypress/bp-forums
    9. upload rest of the latest version buddypress files
    10. go to your dashboard >Buddypress > components >forums click to install group forums and it will create a new bb-config.php file
    11. create a new group – DO NOT SELECT ENABLE DISCUSSION FORUM
    12. save the group
    13. go back into the group and select enable discussion forum
    14. create a new topic for your new forum
    15. If it works – check the other groups.
    16 If the other groups don’t work – de-select enable discussion forum and save – then select discussion forum and save again – see if that helped.
    17. change to your custom theme – double check again. You may need to redo step 16 for some of your groups
    18. reactivate your plugins and check again – you may need to redo step 16

    I know that seems like a lot of steps – and possible you could skip some of them – but that’s the exact process I used and it worked… woot!!

    Good luck


Viewing 21 replies - 1 through 21 (of 21 total)
  • The topic ‘Buddypress forums not working’ is closed to new replies.
Skip to toolbar