Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buttdy Press 7.3.0 Conflicts with Elementor


  • fraughtithrouble
    Participant

    @fraughtithrouble

    Every since the BuddyPress new update, I can no longer edit pages in my Buddy X Pro themed BuddyPress site. All plugins turrned off, and can edit, until I turn on BuddyPress.

    Here is the error produced:

    When I attempt to edit with Elementor I get a 500 internal server error. Sometimes there is left in the php error log, this error, but not every time I get the 500 internal server error

    Here is my Environment and error log from the Elementor System Info…

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: MySQL Community Server (GPL) v5.7.33
    PHP Version: 7.3.27
    PHP Max Input Vars: 10000
    PHP Max Post Size: 512M
    GD Installed: Yes
    ZIP Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 5.7
    Site URL: https://www.crossazure.net
    Home URL: https://www.crossazure.net
    WP Multisite: No
    Max Upload Size: 512 MB
    Memory limit: 1028M
    Permalink Structure: /%author%/%year%/%monthnum%/%day%/%postname%/
    Language: en-US
    Timezone: 0
    Debug Mode: Inactive

    == Theme ==
    Name: BuddyxPro
    Version: 2.6.1
    Author: wbcomdesigns
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0

    == Active Plugins ==
    Absolutely Glamorous Custom Admin
    Version: 6.8
    Author: Cusmin

    BuddyPress
    Version: 7.3.0
    Author: The BuddyPress Community

    Classic Editor
    Version: 1.6
    Author: WordPress Contributors

    Colorlib Login Customizer
    Version: 1.2.99
    Author: Colorlib

    Elementor
    Version: 3.1.4
    Author: Elementor.com

    Elementor Pro
    Version: 3.2.1
    Author: Elementor.com

    Kirki Customizer Framework
    Version: 3.1.6
    Author: David Vongries

    Wordfence Security
    Version: 7.5.2
    Author: Wordfence

    WPSSO Core
    Version: 8.26.2
    Author: JS Morisset

    == Elementor – Compatibility Tag ==

    Elementor Pro: header_not_exists

    == Elementor Pro – Compatibility Tag ==

    == Elements Usage ==

    wp-page : 3
    button : 2
    heading : 2
    icon : 11
    image : 1
    bpb-buddypress : 0
    bpb-members-directory-filters : 1
    bpb-members-directory-list : 1
    bpb-profile-member-avatar : 1
    bpb-profile-member-buttons : 1
    bpb-profile-member-content : 1
    bpb-profile-member-cover : 1
    bpb-profile-member-username : 1
    icon : 26
    spacer : 1

    == Log ==

    PHP: showing 2 of 2PHP: 2021-04-12 14:03:52 [notice X 2][/home/crossazure/public_html/wp-content/plugins/elementor-pro/license/updater.php::75] Undefined index: new_version [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2021-04-14 08:56:53 [error X 27][/home/crossazure/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php::2038] Uncaught TypeError: Argument 1 passed to Elementor\Controls_Stack::sanitize_settings() must be of the type array, null given, called in /home/crossazure/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php on line 987 and defined in /home/crossazure/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php:2038
    Stack trace:
    #0 /home/crossazure/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php(987): Elementor\Controls_Stack->sanitize_settings(NULL)
    #1 /home/crossazure/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php(1787): Elementor\Controls_Stack->get_data(‘settings’)
    #2 /home/crossazure/public_html/wp-content/plugins/elementor/core/base/base-object.php(142): Elementor\Controls_Stack->get_init_settings()
    #3 /home/crossazure/public_html/wp-content/plugins/elementor/core/base/base-object.php(40): Elementor\Core\Base\Base_Object->ensure_settings()
    #4 /home/crossazure/public_html/wp-content/plugins/elementor/includes/base/contro [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]

Viewing 4 replies - 1 through 4 (of 4 total)

  • vapvarun
    Participant

    @vapvarun

    @fraughtithrouble submit a support ticket, I will check
    THE current BP update is a minor update that should not create conflict with the elementor. You can also downgrade to the previous version using the WP Rollback plugin


    fraughtithrouble
    Participant

    @fraughtithrouble

    Will all my plugins enabled, if I disable BuddyPress 7.3.0, Elementor can edit, but if I enable it it cannot. I rolled back to the previous version of BuddyPress and the problem persists.

    I was editing with both plugins enabled 14 hours ago, without problems, but now there is this conflict. I updated to elmentor pro 2 days ago, and had no problems. I installed Short Codes for Elementor and BP, some 12 hours ago, and after that when I attempted to edit with Elementor I encountered this problem. I raised the php memory to 1GB and uninstalled that plugin, and the problem persists, even with all plugins off except elementor and buddypress, the problem reoccurs. So perhaps it is more accurate to say that Short Codes for Element and BP may have caused a persistent conflict between Elementor and BuddyPress, when editing with Elementor. (Site functionality not otherwise impaired).

    My site is a development site, so I have to fix this problem to continue developing with Elementor.


    fraughtithrouble
    Participant

    @fraughtithrouble

    I should add that as soon as this conflict occurred my managing hosting found the tables of mhy database damaged and repaired them. So that too might be an issue. But after the repair, the problem persists.


    fraughtithrouble
    Participant

    @fraughtithrouble

    With further testing, I have found that the conflict arises ONLY WHEN EDITING a page assigned by A BUDDY PRESS as one of its 3 core pages. I can edit a new page i elementor. And I can edit a page which was assigned, but is not currently assigned, as one of the three pages.

    I can work around this, but its still a problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar