Skip to:
Content
Pages
Categories
Search
Top
Bottom

confirmation emails are not sent for new users

Viewing 4 replies - 1 through 4 (of 4 total)

  • frangdelsolar
    Participant

    @frangdelsolar

    I’m having the same problem!


    despostillar2009
    Participant

    @despostillar2009

    You found some possible solution??


    vidyen
    Participant

    @vidyen

    Hi, I just noticed this as well. Was there an update on Buddypress? I don’t remember updating the plugin. Or was it something on google’s end?

    I get other WP emails just fine. I thought it might be due to @site.com">noreply@site.com wasn’t a valid email just not working.

    I use another registration form and that sends email, but its annoying as the buddypress assigns correct role.


    r-a-y
    Keymaster

    @r-a-y

    If you’ve already tried the solutions in this thread:

    BuddyPress 3.1.0 is now available!

    Then, here are a couple of other possible solutions:

    1) Remove the “Reply-To” email address from BuddyPress emails.

    By default, BuddyPress adds a “Reply-To” email header to each BuddyPress email containing the admin user’s email address.

    I’m guessing email senders might have problems with this because the “From” email address and the “Reply-To” email address could use different domains. Email senders might think this is spammy and would reject the email. Just a guess. You’d have to look in your email logs to confirm.

    Anyway, here’s a code snippet you can try in your theme’s functions.php or in wp-content/bp-custom.php:

    add_filter( 'bp_email_set_reply_to', function( $retval, $email_address ) {
    	// Wipe out Reply-to email header if it matches the admin email address.
    	if ( bp_get_option( 'admin_email' ) === $email_address ) {
    		$retval = new BP_Email_Recipient( '' );
    	}
    
    	return $retval;
    }, 10, 2 );

    2) Try setting a different “From” email address

    If you are having problems sending any email on your WordPress install, you might have to set the “From” email address to one that contains your website domain.

    There are a few plugins that can do this. Here are a couple:

    Change From Email

    WP Change Default From Email

    3) Try using a WordPress email SMTP plugin

    If all the above fail, try a SMTP email plugin:
    https://wordpress.org/plugins/tags/smtp/

    —-

    Please let me know if either of the solutions work.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Skip to toolbar