Skip to:
Content
Pages
Categories
Search
Top
Bottom

Error Logs with BuddyPress


  • Fobulis
    Participant

    @fobulis

    Hi,

    I’ve recently installed Buddypress to my WP theme and i’ve been facing some issues. Everytime I try to uninstall or deactivate the theme I get this error msg:

    Warning: ksort() expects parameter 1 to be array, null given in /home/abdulahmed/public_html/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 214
    
    Warning: reset() expects parameter 1 to be array, null given in /home/abdulahmed/public_html/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 219
    
    Warning: current() expects parameter 1 to be array, null given in /home/abdulahmed/public_html/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 223
    
    Warning: next() expects parameter 1 to be array, null given in /home/abdulahmed/public_html/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 229
    
    Warning: current() expects parameter 1 to be array, null given in /home/abdulahmed/public_html/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 223
    
    Warning: next() expects parameter 1 to be array, null given in /home/abdulahmed/public_html/wp-content/plugins/buddypress/bp-core/bp-core-template-loader.php on line 229
    

    And this will just go on creating many warnings. It activates fine and the functionality seems to be fine as well. However, this problem is taking up massive bandwidth and my hosting service is not liking it. I can’t seem to find the issue. I’ve used FTP to check the naming conventions and the directory is in the right place. Any ideas?

    Thanks in advance

Viewing 4 replies - 1 through 4 (of 4 total)

  • Venutius
    Participant

    @venutius

    Have you tried raising this with your theme’s creators, this seems more like a theme problem than a BuddyPress issue.


    Henry Wright
    Moderator

    @henrywright

    I’ve recently installed Buddypress to my WP theme

    Can you explain exactly the steps you took?


    Fobulis
    Participant

    @fobulis

    Yes, i’ve discussed this with the theme creators and was told it was an issue with the plugin. However, I cannot seem to isolate the problem. I imported the theme using the .zip file and activated it. Then activated the associated plugins after that, including BP. But BP cannot be deactivated and keeps mass producing these error logs.


    shanebp
    Moderator

    @shanebp

    i’ve discussed this with the theme creators and was told it was an issue with the plugin.

    Try switching to a WP theme like 2015.
    Do the warnings stop appearing?
    If so, then the problem is caused by something in your preferred theme.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error Logs with BuddyPress’ is closed to new replies.
Skip to toolbar