Skip to:

Error with Forum BP v1.2.5.2

  • Thorsten :-)


    Hi everybody!
    I cannot post any topic in my Forum. I installed a fresh BP Forum. File ‘bb-config.php’ had been created, tables ‘wp_bb_forums’, ‘wp_bb_meta’, ‘wp_bb_posts’, ‘wp_bb_term_relationships’, ‘wp_bb_terms’ and ‘wp_bb_topics’ had been created correctly. My Groups work fine. The only thing which does not work is to publish a topic. After publishing a topic I get the hint of an publishing error.

    I use Windows 2003 Server IIS 6, ISAPI Rewrite 3 (Helicon), PHP 5, mySQL 5, BP v1.2.5.2, WP 3.0.1 and Fishbook theme …

Viewing 2 replies - 1 through 2 (of 2 total)
  • I had this problem and have finally solved it.

    Here’s what I did:

    1. deactivate all plugins except buddypress
    2. change theme to default
    3. backup your bb-config.php file
    4. delete bb-config.php
    5. backup /public_html/wp-content/plugins/buddypress/bp-forums
    6. rename /public_html/wp-content/plugins/buddypress/bp-forums
    7. download the latest version of Buddypress
    8. upload new version of /public_html/wp-content/plugins/buddypress/bp-forums
    9. upload rest of the latest version buddypress files
    10. go to your dashboard >Buddypress > components >forums click to install group forums and it will create a new bb-config.php file
    11. create a new group – DO NOT SELECT ENABLE DISCUSSION FORUM
    12. save the group
    13. go back into the group and select enable discussion forum
    14. create a new topic for your new forum
    15. If it works – check the other groups.
    16 If the other groups don’t work – de-select enable discussion forum and save – then select discussion forum and save again – see if that helped.
    17. change to your custom theme – double check again. You may need to redo step 16 for some of your groups
    18. reactivate your plugins and check again – you may need to redo step 16

    I know that seems like a lot of steps – and possible you could skip some of them – but that’s the exact process I used and it worked… woot!!

    Good luck




    @inweb thank you for sharing your solution to current WP 3.3 and BP 1.5.2 forums. However, this thread is more than a year old and solution was different. Closing this thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Error with Forum BP v1.2.5.2’ is closed to new replies.
Skip to toolbar