Skip to:

Forum – cannot post in old groups

  • Hi

    I just killed my old BBpress install and went for the new one click in BP 1.1.1.

    Everything is ok, but it seems I cannot post in a group that had the “old” forum once enabled. It gives me an error. In newer groups (no forum before) it seems to work just fine.

    Ps: This is my interpretation of what could cause the error…

    Any ideas and solutions to this?

Viewing 25 replies - 1 through 25 (of 36 total)
  • Another little bug – maybe attached to that one: I just posted a topic (in a newer group) and then it got also published in another older group… strange…

    Any ideas, why that could be? It is kind of a bad-bug for me, because we cannot delete and re-create all of the old groups…

    Thanks for your help!



    i had the same trouble.

    Old table were bb_prefixed

    the new table have wp_bb_prefix…

    What you can do is to copy the old content into the new tables to have things to work. And to play a little with the “one click” forum intergration. This is even false: it needs 2 clicks. :-)

    What do you mean by “Play”… sorry, I am not much of a coder… I do not need the old content, but I need the forums to work in old groups. Would be great, if you could give me a step by step guide :-) (if that is not asking too much)

    Thanks already!

    I really need a solution to this? Can anyone help me and tell me what exactly I need to do?

    1. I do not need the old content . I deleted the old BBPress Installation

    2. I need to work the new (“one-click”) forum to work in old groups, where the old forum was activated

    What can I do?


    Jeff Sayre


    but it seems I cannot post in a group that had the “old” forum once enabled. It gives me an error.

    What is the error?

    I have a german version, but I try to translate:

    There was an error posting your topic

    (a red “singn” above the title of the group…)

    Jeff Sayre


    Did you choose “Set up a new bbPress installation”” or “Use an existing bbPress installation”?

    If you do not need any of the old bbPress content, then I would suggest starting the bbPress integration from scratch. This mean deleting the old and newly-created bbPress tables in the DB, then deleting the bbPress directory from BuddyPress, and then reinstalling the bbPress files. This of course also assumes that the new bbP tables do not yet have any worthwhile data in them.

    Next, go back into WPMU’s backend and navigate to “BuddyPress > Forums Setup” and then choose “Set up a new bbPress installation”.

    Does that make a difference?

    thanks – I will try that, after I am back from vacation :-) … I will report then…

    Hi Jeff

    so I am back and I tried your suggestion:

    1. Deleted the old bb-tables

    2. Deleted the new wp_bb tables

    3. Deleted the old BB Install

    4. Reintegrated the forum install (did it again)

    BUT still does not work.

    Posting in new groups that didn’t have the old forums activated works

    Psoting in older groups that had the old forum activated still does NOT work

    Any more ideas???

    Hmmmm – nobody else having this issue? I am having the exact same issues on two different installs… One subdomain and one subdirectories…

    It’s pretty much a blocker, so I would welcome any more help! :-)

    Thanx already!

    In the group’s admin page, disable the forum, then re-enable it.

    Thanks for the hint, Andy, but I tried that one (i remembered from older upgrades)

    I just did it again, but still the error occurs… :-(

    No one experiencing this? I don’t give up :-)!

    Jeff Sayre



    You state above that you do not need the old bbPress data. If that is the case, then I recommend that you do a clean install of BuddyPress.

    Follow this procedure:

    • Make a backup copy of your MySQL DB just in case
    • Deactivate all BP-dependant plugins
    • Deactivate BP
    • Delete all the bbPress-specific tables in your DB
    • Delete the old BP files located in the /buddypress/ directory
    • Upload a fresh copy of BP 1.1.2, move the contents of /bp-themes/ into their proper place
    • Reactivate BP
    • Go to the forums setup submenu under the BuddyPress menu and select the “Set up a new bbPress installation” option

    Does that solve the issue?

    I did step by step everything mentioned above (that was a WPMU & BP Upgrade for me too). The error is not only still there, now I cannot post any topic in any group. Always that red error. Very strange.

    Any more ideas or experiences from anybody?

    Jeff Sayre


    As this issue is quite perplexing, perhaps we should keep the discussion here instead of via PM. That way, others can benefit as well.

    You mentioned in one of your PMs that both your BP installations are active. This means that you cannot start over with a clean MySQL table.

    However, for purposes of isolating this problem, can you create a third installation on your live server. This way, we will know whether or not an absolutely clean, vanilla install (new MySQL DB, new WPMU and BP install using the default BP theme with no 3rd-party plugins) works on your server environment, works on the server your web host has provided to you.


    I already did this. It was a fresh install where the old-bbpress-forums never had been installed. There it works without any troubles… Same server.

    Could the table wp_bp_groups_groupmeta have something to do with it. There I find a couple entrances like with the meta-key “forum_id”…

    Jeff Sayre


    Okay, we can rule out some strange server configuration issue.

    If I remember correctly, you used to have bbPress running via deep integration but did not need any of that old data. The very first time you tried using the new one-click forum setup, did you choose the “Existing bbPress Installation” or the “New bbPress Installation” option?

    Do you still have a backup copy of your old bb-config file? If so, then delete the current bb-config.php file by replacing it with your old bb-config.php file. Then go to the WPMU backend and visit “BuddyPress > Forums Setup” and click the “re-install” link. At this stage, it is worth a try.

    Please note, using an “Existing bbPress Installation” does not really mean using the old bbPress files. It means use an existing bb-config file to setup bbPress with the bbPress files located in the new location. You will see this text at some point in the process:

    BuddyPress will now use its internal copy of bbPress to run the forums on your site. If you wish, you can remove your old bbPress installation files, as long as you keep the bb-config.php file in the same location.

    Yes: Deep integration, killed the old data and chose “new bbPress Installation” (if I would have known what you just mentioned with “using an existing install”, I guess I would have done this, because I understud that wrong).

    Sadly I don’t have the old bb-config.php anymore (from deep integration), so I cannot do this. Besides the old config-file I tried that reinstall option a couple times (as far as I can see, this just creates a new bb-config.php in the root).

    Some thoughts/questions:

    1. Why does it after the upgrade not work at all. with BP 1.1.1. and WMPU 2.8.4 at least the newer groups which never had any forum-data from the depp-integration-time had in them worked…

    2. When my Test-Install on the same server works it seems to me that there must be somewhere any leftover data from the deep-integration-times that confuses the new forum-setup. So wouldn’t it help to find out where (in files, db, etc) is ANY information regarding the forums stored (like my question above about the wp_bp_groups_groupmeta table). That way we could work our way through…

    Ps: In the process I already deactivated ANY Plugins (not only BP-related) – but it did not change anything. So it seems it’s not a plugin conflict…

    Jeff Sayre


    Unfortunately, I do not have any dev sites that have meta data from the old, deep-integration bbPress forum days. I blow out everything (data and files) when I upgrade. I want a clean install for all dev work. Old test data is worthless to me.

    Perhaps jjj or someone else can chime in and help Michael work through the possible issue of orphaned bbPress meta data.

    Thanks Jeff for all your hard forum-sherlock-holmes-work. :-)

    Would be great if triple-j (as far as I remember he messed alot with the “Old-ways” :-)) could jump in or some other gurus…

    Jeff Sayre



    I’ve contacted jjj to ask for his insight regarding your issue. Between his bug-fixing work and upcoming travel to NY this weekend to participate in WordCamp, I’m not too sure whether he will have any time until next week.

    Thanks alot! I will try to be patient! :-)

    Jeff Sayre



    Based on the fact that you’ve been struggling with this issue for 3 weeks without blowing a gasket, I think it is safe to say that you have already demonstrated patience!

Viewing 25 replies - 1 through 25 (of 36 total)
  • The topic ‘Forum – cannot post in old groups’ is closed to new replies.
Skip to toolbar