Skip to:

Forum – cannot post in old groups

  • Hi

    I just killed my old BBpress install and went for the new one click in BP 1.1.1.

    Everything is ok, but it seems I cannot post in a group that had the “old” forum once enabled. It gives me an error. In newer groups (no forum before) it seems to work just fine.

    Ps: This is my interpretation of what could cause the error…

    Any ideas and solutions to this?

Viewing 11 replies - 26 through 36 (of 36 total)

  • John James Jacoby


    I’ve got 1 guess…

    Go to your wp_sitemeta table and find the meta_key “bb-config-location” and tell us what you see.

    I got $5 that says it’s pointing to your old location that is long since deleted. If I’m correct, delete that from the DB and re-run the one-click integration again.

    Jeff Sayre



    That’s a great suggestion. However, I would have thought that when Michael tried using the “re-install” link in “BuddyPress > Forums Setup”, that the proper bb-config.php location would have been saved.

    Perhaps there are two–or more–conflicting meta data entries for the location of a bb-config.php. That’s what I’m now guessing.

    Delete all the “bb-config-location” entries except for the proper one and it should work. Although, it might require starting the install process over once again. This means deleting all the bb tables and the config file AND any and all entries for “bb-config-location”.



    ***** for Michael’s patience !

    ***** for Jeff Sayre’s patience too !

    **************** for the problem who resist !

    @jjj: Thanks for the hint – it seemed logical… BUT, it also seems, that the path for the bb-config-location is correct (htdocs/bb-config.php). So who gets the $5?

    : I also searched the entire DB for the term “bb-config-location” but it was only found in the wp_sitemeta table :-(

    You guys are great! I got also $5 for the person who catches the “evil-doer” :-)

    If it helps I could grant you access to my installation and DB – for I am not a programmer or something, just a greenhorn who tries to find its way through the jungle of the virtual world… :-)

    Jeff Sayre


    Correct. The meta key “bb-config-location” will only be located in the wp_sitemeta table. What I was suggesting is that their may be duplicate (multiple) entries of the “bb-config-location” meta key within the wp_sitemeta table.

    Make sure that you have throughly scanned the entire table for that possibility. I have seen this happen with other meta key, meta value pairings before.

    John James Jacoby


    Darn… I was pretty positive I was right on that one… Ha!

    I’d PayPal you $5, but if I fix your problem we’re even. :)

    @jeff: Thanks again for the hint. When it comes to DBs it kind of scares me, because I almost know nothing. But as far as I can tell there is only one “bb-config-location” in the wp_sitemeta table and this seems fine…

    Jeff Sayre


    What application are you using to view your MySQL DB? Many people use phpMyAdmin. What ever application you are using, make sure that you have first determined how many rows your wp_sitemeta table contains.

    In my version of phpMyAdmin, it defaults to showing only 30 records at a time. So, if there are more than 30 rows in a given table, and you are not aware of that fact, it can be easy to assume that all available records are being displayed–even when there are buttons to advance to the next set or records. Of course, there are a few ways to change the default value so that more (or all) records are showed.

    Thanks Jeff. Sadly I saw that before and looket at all of the rows… So it seems there really is NO other entry.

    Any news/ideas on this? I must say, I am kind of desperate…!

    So – I just upgaded to 1.2.1 and thought: give it a new shot… But still doesn’t work :-( Not too bad, because with 1.2 I don’t need the forums anymore (looking forward to a tagged new solution…).

    But still it seems strange, that this just happens to me… Maybe I really messed the forums up one time…

Viewing 11 replies - 26 through 36 (of 36 total)
  • The topic ‘Forum – cannot post in old groups’ is closed to new replies.
Skip to toolbar