Skip to:

Group forum post – \\\"There was an error posting that topic\\\"

  • r-a-y


    I don’t know where this one came from, but here we go.

    *Note this is on a different install of BP – WPMU 2.7.1 and BP 1.0.2.

    Group forum posts were working in BuddyPress, up until recently

    Now, when I try to make a group forum post, I get a “There was an error posting that topic.” in BP.

    The forum shows up in bbPress, just no topic.

    -Single sign-on works in WPMU and bbPress

    -I’ve tried disabling and re-enabling discussion forum for the BP group in question.

    -I disabled and re-enabled the BP forum component in “WPMU Admin > BuddyPress > Component Setup”

    -Double checked that the XMLRPC line is at the bottom of bb-config.php

    -BuddyPress Forums setup uses same username and password as keymaster in bbPress

    Is there anything I’m overlooking?

Viewing 11 replies - 1 through 11 (of 11 total)

  • r-a-y



    -I used Burt’s XMLRPC debugger to see if it was an XMLRPC problem and it seems like it is as I’m getting the following error:

    -32700 >> parse error. not well formed

    Now I need to know how to solve this problem.

    The thing is though when I try to make a BP group forum post, the forum shows up in bbPress, just no topic. So XMLRPC has to be working to some extent right?

    Hopefully either one of the mods or someone can answer the following question:

    I have a bunch of bbpress_live_cache entries in the db from when group forums were actually working.

    Should I clear the bbpress_live entries in the db?

    Jason Giedymin


    I can confirm i have a similar issue, but ONLY with trunk (with no XMLRPC errors).

    1.0.3 works fine for me.

    If anyone uses trunk BuddyPress, they should be prepared for errors and for things to be broken.



    Bumping this thread again.

    Any help would be very much appreciated.

    Should I just reinstall bbPress 1.01?



    Okay I got forums up and working and again!

    This was the weirdest thing… the bbPress forums – xmlrpc.php – was somehow larger in filesize than the release version.

    I overwrote the /forums/xmlrpc.php from the one in the bbPress 1.0.1 package and now group forums are working again!

    Jeez louise!

    John James Jacoby


    I find strange things like this happen if I FTP a file directly from inside a zip file, rather than unzipping it and uploading it.

    It’s a good feeling when the arm flailing and panic file replacement works out. :)



    I find strange things like this happen if I FTP a file directly from inside a zip file, rather than unzipping it and uploading it.

    That’s exactly what I did… uploaded from a .ZIP file. I’m rather lazy that way! ;)

    I was stressing out over this for a couple of days!



    Hey r-a-y I tried to get to burts website and download his XMLRPC- debugger but his site is down or something it just says address can not be found. I have the same problem you did where I can not post to the group forum but a new forum gets created for the group on the forum’s main page. Not sure what to do at this point. Maybe you can send me an email with the debugger so i can check for the errors that are causing this.

    I also tried downloading a new xmlrpc file and replacing it with my current one but no help there it was the same file size.

    Thanks for any help or guidance to a solution,


    Oh I am using all the up to date wpmu buddypress and bbpress software available.



    Hey pengume,

    You’re lucky! I didn’t have a copy of Burt’s XMLRPC debugger on my localbox, but I was able to find a copy off a server I used it on before!

    Here’s the mirror:

    To install, put “oci-bb-sayhello.php” in your “my-plugins” folder in your bbPress install and activate it in your bbPress admin area.

    Then, put “oci-bp-sayhello.php” in your WPMU root folder and go to that file.

    eg. hxxp://

    If you have any errors, the script will output them; if there are no errors, you’ll get a “Hello from bbPress!” return message.

    Hope that helps!



    Alright worked perfectly well atleast the debugger did I am getting an error -32301 >> transport error – HTTP status code was not 200

    I have seen this before on a different topic and someone said it was due to a server issue or hosting issue but didn’t really see any resolve. So I called my host and absolutely no idea or help was attained mostly confusion on this topic. The support just told me that everything is running smoothly and we don’t understand why your getting this error. She even made me email a screen shot. And then still didn’t understand. Any idea’s on what I should do maybe a different host for starters? Thanks for the link to the debugger and instructions r-a-y always appreciate the help.



    I found the stupid working solution.. it’s a little bit illogical but worked 100%

    1 – Delete your group.. doing the other way around is impossible for non-developers.

    2 – Create a the new group..
    STEP 1 add title and description ( title will be used as the group slug )
    STEP 2 ( DO NOT SAVE SETTING AS IS!! I REPEAT DO NOT!!!! ) here’s what to do.
    in step 2 ((un-check)) the Enable discussion forums, and then check it again.. and THEN save settings..
    Step 3 avatar bla bla.. but the thing is :) it’s solved!

    How it works!

    the problem is stupidly simple.. that in some times.. ( not all buddypress installations for some weird reason either plugin conflict or a script timing error…

    the check of enable forums is saved as “null” instead of 0/1 imagine it as a multiple choice radio button..

    as long as you didn’t either.. it’s unselected.. but once you click.. it’s always 1 of the both and can’t be null…

    Why is this happening? even WPMU and BPMU geniuses couldn’t solve it for 2 years now ^__^’>

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Group forum post – \\\"There was an error posting that topic\\\"’ is closed to new replies.
Skip to toolbar