Skip to:
Content
Pages
Categories
Search
Top
Bottom

Having trouble enabling the buddypress blogs section


  • darkray16
    Member

    @darkray16

    Hello,

    I’m having trouble getting the blogs link to show up in the bp navigation bar. And everytime I go to http://www.mywebsite.com/members/username/blogs it redirects me back to http://www.mywebsite.com .

    Is this because I haven’t enabled WP Multisite? Currently, I’m using the single site option. The only way I can view blog posts is by looking at the activity stream. I want add an item on the nav menu that can take people to a list of all blog posts by displayed user.

    Thanks for any advice.

Viewing 4 replies - 1 through 4 (of 4 total)

  • @mercime
    Keymaster

    @mercime


    darkray16
    Member

    @darkray16

    All of those options don’t involve buddypress. I thought there was built in support for it in buddypress as there is a “blogs” folder in the bp-default theme, and there is a index page, and blog loop file in that folder.


    mrjarbenne
    Participant

    @mrjarbenne

    The “Blogs” button you would normally see in the bp-default theme only exists on a multisite installation. There are no “blogs” on a single install; only one “blog”. In order to see the blogposts created on the main blog (the only blog in your case), you would need to go to the Profile page and use the filter on the Activity Stream to view only Blog Posts.

    I have a similar problem. I’m using WP 3.2.1 and BP 1.3. If I use the default BP theme my main (and only) blog shows. However, if I use other themes, I am not able to get my posts to appear on my “Blog” page.

    In the interim, I have put “Featured Category”, “Recent Posts” and “Recent Comments” on the sidebar of pages and posts on the front page to allow people access to blog posts.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Having trouble enabling the buddypress blogs section’ is closed to new replies.
Skip to toolbar