Skip to:

Installed BP for second time, worked the first time not now…

  • HI everyone,
    I have decided to try to intergrate buddypress with my existing MU install for the second time now (using wp3.0 and thesis theme). The first time i did it, via the template pack, it all seemed to work fine. But i reconsidered as another project came up, and uninstalled it.

    I now have time to make it work again, have installed again, and the old setting seemed to be saved in the admin pages etc.. I also get the admin bar showing in the backend (but not the front end) and all the links in the admin bar just redirect to the homepage.

    Any advice would be great. Even if there is a way to do a clean uninstall, happy to do it, but not sure what bits i’d need to delete!

    My website is,


Viewing 6 replies - 1 through 6 (of 6 total)

  • @mercime


    Did you change permalink settings to other than default? If that doesn’t work, change theme to bp-default theme.

    i can’t change the theme to bp-default theme, it has to be able to be integrated into my live site.

    the permalink structure does get changed with the change to wp3.0, can you let me know what it needs to be to work?
    thanks :)

    here’s and example of a BP page link that doesn’t work –

    Admin bar not appearing in front end is probably because your theme doesn’t call wp_footer()? And what is your permalink structure, can you share it here?

    Hi, the admin bar is showing now (my fault i had the plugin that hid it still enabled from last time) the permalink structures is – month & name – ie

    thanks again :)

    Hmm. Looks like the plugin is active at the moment (I see a javascript include). I also see a lot of other plugins; if you’ve got a test server I suggest disabling all the plugins other than BuddyPress and seeing if it works. I suspect this is likely due to a conflict.

    Another idea is, when you previously ran the BP Template Pack, did you restore your theme’s files to defaults? e.g. removed the BuddyPress stuff it added. Also, as far as I’m aware, you can disable the BP Template Pack — it’s a once-off thing.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Installed BP for second time, worked the first time not now…’ is closed to new replies.
Skip to toolbar