Skip to:
Content
Pages
Categories
Search
Top
Bottom

JobRoller + BuddyPress errors

  • Hi There;

    I recently imported my website from ning to wordpress buddypress and JobRoller but it has been already around a week and i couldn’t fix the errors

    As you can see for e.g the footer “Copyright © 2011 LinkYou.info. Job Board Software | Powered by WordPress” is in the top of the page were it should be in the bottom of the page

    that error you would see it in buddypress pages as e.g.

    http://www.linkyou.info/members/test/activity/

    you can use
    user name : test
    password: 123456

    i hope some one could help as have the same errors in Activities, Friends, groups and all other pages

Viewing 13 replies - 1 through 13 (of 13 total)
  • can any one please explain this

    If BuddyPress pages are not aligned correctly then you will need to modify some of the templates to match your theme’s HTML structure. The best way to do this is to FTP to your theme’s files at:

    /wp-content/themes/jobroller/

    Then open up the page.php file (if this does not exist use index.php). Make note of the HTML template structure of the file, specifically the `

    ` tags that surround the content and sidebar.

    You will need to change the HTML structure in the BuddyPress templates that you copied into your theme to match the structure in your page.php or index.php file. The files that you need to edit are as follows (leave out any folders you have not copied over in step two):

    /activity/index.php
    /blogs/index.php
    /forums/index.php
    /groups/index.php
    /groups/create.php
    /groups/single/home.php
    /groups/single/plugins.php
    /members/index.php
    /members/single/home.php
    /members/single/plugins.php
    /registration/register.php

    Once you are done matching up the HTML structure of your theme in these template files, please take another look through your site. You should find that BuddyPress pages now fit inside the content structure of your theme.


    @mercime
    Keymaster

    @mercime


    Virtuali
    Participant

    @gunju2221

    I find that very confusing also, in fact, I think it’s not really necessary.

    Undo your changes that you did to follow Peatlings Template pack instructions.

    The biggest thing that you need to do for custom theme is import the CSS+ functions, and make your CSS fit inside your theme, and your good to go.

    There might be other theme adjustments you might need to do, but I can’t speak for your theme.

    P.S @mercime, something screwed up the structure of this topic, but it’s weird, no code was posted! :???:


    @mercime
    Keymaster

    @mercime

    @gunju2221 maybe it’s corrected now, don’t see screwed up structure. What’s strange is that your @ mention to me did not appear in my profile at all. Just came upon this now.


    Virtuali
    Participant

    @gunju2221

    @mercime, it’s because the @mention was after the excerpt on the profile activity stream. It’s weird.

    Notice how our posts are somewhat indented?


    @mercime
    Keymaster

    @mercime

    @gunju2221 OK, didn’t see indentation at all in FF and Chrome but finally saw what you meant when I opened Safari.
    Checked what could have caused that – like open UL or what. Adding backticks around `

    ` tag mentioned above has resolved the issue in Safari for me. Strange but true :-)

    @mercime i did the steps mentioned in the two links provided but it is not working
    @Virtuali how to import the CSS+ functions


    Virtuali
    Participant

    @gunju2221

    @linkyou, add this to your theme’s css:

    `
    /* Inherit the default theme styles */
    @import url( ../../plugins/buddypress/bp-themes/bp-default/_inc/css/default.css );

    /* Inherit the default theme adminbar styles */
    @import url( ../../plugins/buddypress/bp-themes/bp-default/_inc/css/adminbar.css );
    `

    And put this in your functions.php

    `// Load the AJAX functions for the theme
    require_once( TEMPLATEPATH . ‘/_inc/ajax.php’ );

    // Load the javascript for the theme
    wp_enqueue_script( ‘dtheme-ajax-js’, get_template_directory_uri() . ‘/_inc/global.js’, array( ‘jquery’ ) );

    // Add words that we need to use in JS to the end of the page so they can be translated and still used.
    $params = array(
    ‘my_favs’ => __( ‘My Favorites’, ‘buddypress’ ),
    ‘accepted’ => __( ‘Accepted’, ‘buddypress’ ),
    ‘rejected’ => __( ‘Rejected’, ‘buddypress’ ),
    ‘show_all_comments’ => __( ‘Show all comments for this thread’, ‘buddypress’ ),
    ‘show_all’ => __( ‘Show all’, ‘buddypress’ ),
    ‘comments’ => __( ‘comments’, ‘buddypress’ ),
    ‘close’ => __( ‘Close’, ‘buddypress’ ),
    ‘mention_explain’ => sprintf( __( “%s is a unique identifier for %s that you can type into any message on this site. %s will be sent a notification and a link to your message any time you use it.”, ‘buddypress’ ), ‘@’ . bp_get_displayed_user_username(), bp_get_user_firstname( bp_get_displayed_user_fullname() ), bp_get_user_firstname( bp_get_displayed_user_fullname() ) )
    );
    wp_localize_script( ‘dtheme-ajax-js’, ‘BP_DTheme’, $params );`

    Should put styles of the buddypress default theme into your theme. I would go into plugins/buddypress/bp-themes/bp-default/_inc/css/default.css and remove all the contents of:

    `/* > Global Elements


    */
    /* > Admin Bar


    */
    /* > Header


    */
    /* > Navigation


    */
    /* > Container


    */
    /* > Sidebar


    */
    /* > Content


    */`

    @Virtuali @gunju2221 thanks a lot for giving your time to help me out

    i did the steps you mentioned above but still the same, below are the steps i did please correct me if i am wrong

    1. I went to plugins/buddypress/bp-themes/bp-default/_inc/css/default.cs and removed all the contents of
    /* > Global Elements


    */
    /* > Admin Bar


    */
    /* > Header


    */
    /* > Navigation


    */
    /* > Container


    */
    /* > Sidebar


    */
    /* > Content


    */

    2. Went to /wp-content/themes/jobroller/css/style-pro-blue.css
    and added the code to the end after
    .widget_calendar table {
    width: 100%;
    }

    3. Went to /wp-content/themes/jobroller/functions.php
    and added the code to the end after

    /**

    * add any of your custom functions below this section

    and before

    */

    ?>

    for example please view this link
    http://www.linkyou.info/forums/

    @gunju2221 what do you think


    Virtuali
    Participant

    @gunju2221

    Is that your site above?

    Thats just the default theme.


    Tony Locke
    Participant

    @tonylocke

    well, I don’t know what part of the file to change. I loaded the compatibility plugin templates, loaded the BP Sidebar plugin, even got the theme tag-ged buddypress to get rid of the message.

    when I open up the widgets I see the Buddypress sidebar widgetized areas, but no matter what I place in there I can’t get them to show.

    I guess I need to learn how to “make note of the HTML template structure of the file, specifically the

    tags that surround the content and sidebar.”
    will someone hold my hand through that process please?

    http://www.OpenVolunteers.com

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘JobRoller + BuddyPress errors’ is closed to new replies.
Skip to toolbar