Skip to:

Links not working. all show homepage. Permalinks are set but will not work?

Viewing 12 replies - 1 through 12 (of 12 total)

  • darbymanning


    I have exactly the same problem. Visited your site and it seems to work fine though – so I am guessing you worked out what was wrong? If so – please share!

    My site is at:



    I’m having exactly the same issue. ( Members directory, blogs, forums, groups just redirect back to the homepage. Also, when I click on my own profile link it redirects back the homepage.I have the same config as above + upgraded BP (versus a fresh install). Variations of this issue seem to exist in several different areas across these forums. Thanks



    Thanks for your posts guys, but I’m still having problems. darbymanning, you say my site worked for you? did you only try the main headings?

    if you go to members, you see the members page, but if you select the only user, Nathan Krisanski to see my profile, it goes back to the home page.

    This happens for most of the pages, ie edit profile etc.

    the actual links appear to be generated properly, but it must be the permalinks that are breaking it. any help out there?

    Andrea Rennick



    Your username has a space in it. The generated URLs are like this: Krisanski/ so there’s no way that will be a valid url.



    Hey Andrea, I have found this is the problem thanks. Can’t work out how to fix it though.

    my username is actually nkrisanski. if you goto, you can see my profile and everything works, but I cannot work out how to tell buddy press to use the correct username in the urls?

    any hints here…

    John James Jacoby


    @darbymanning It looks like you’re using an old BuddyPress theme, with bits and pieces of theme in the wrong spot. Maybe try reuploading BuddyPress and the bp-default theme and try again?

    @nathankisanski BuddyPress by default doesn’t use your displayname for the URL, rather it uses either your nicename or login (I forget which at the moment and it switched a few versions ago.)

    I think the variations of this issue might come from custom themes and how they’re handling the functions that handle the template loading locations. If BuddyPress looks for a template file in a directory, but that file does not exist, you will get bounced back to the root URL of the installation.

    A good example of this happening is if you’re using the old BuddyPress template directory structure, and have the new bp-default theme installed, or vice-versa. Since the old file directory for the members directory was /bp-default/directories/members/index.php (or something like that) and it’s now /bp-default/members/index.php, if BuddyPress is looking for one when really the other is there, you’ll get bounced back to the root when trying to access that page.

    If you’re using an old style theme, there’s a global that needs to be set. ‘BP_CLASSIC_TEMPLATE_STRUCTURE’ will tell BuddyPress to look in the old locations for the template files. Set that in your functions.php for your theme.




    Thanks for your help. It turns out it is using the nicename field for generating the urls. I’m not sure how this is updated in the wp-admin area, but I went into the db and changed this value to be something that doesn’t contain spaces (ie the same as my username) and now it works perfectly.



    Hi all,

    I was actually having this same issue with a site I’m developing, and removing the space from the user_nicename field worked sporadically through the BP “My Account” menu. I’ve created another dummy account or two and it appears they go through a set of checks that the initial user account doesn’t, but removing that space will work.

    An interesting point, if you still can’t get the menu to link properly, try logging in as a non-admin user. I did that after testing for a few hours logged into the admin account, and all’s well!





    Same issue with my site as Graham was saying, only non-admin user account works. In fact, if I don’t log in, clicking on the Admin username from the members page would take me to the blog’s homepage, but clicking on any other members would go to their profiles (which is how it is supposed to work).

    Can’t figure out why though!

    same problems as the others … clicking on the dropdown links at the top of the page just takes me to the front page …except if I log out, in which case they work .

    I am not using the bog standard template for the site but a heavily modded Mimbo theme .. you can see the site here;

    I have deactivated all plugins and the re activated one by one without success so I have a feeling it is some missing code that the BuddyPress template Pack did not manage to install.





    I had the same problem — activity link was the only one that worked.

    I turned off backwards compatibility and now a lot seems to work — not sure about everything … but at least more than was working before.

    Also, I noticed that I hadn’t activated default theme in the theme admin area — maybe that was also an element of it?)



    I believe the problem is solved!

    There must be a minor bug in the new version that I believe is hard to trace on production environment.

    As many others I started with brand new WP (2.9.2) installation + new BP ( on hosted environment. As many others I have encountered problem with permalinks. Tracing down the issue I have relized that the mint installation provides some strange permalink like “/members//messages/sentbox/” with double slashes in it. Newly (generated) user accounts were just fine “/members/user_name/messages/sentbox/”. I have realised that default “admin” user has an empty “nickname” in the WP mint installation (@ standard WP user profile).

    BP uses the EMPTY NICKNAME to generate the PERMALINK and thus it is malfunctioned.

    Solution is simple. Go for the Admin user account (inside the WP/WPMU) and check the nickname. Once having the proper nickname your BP site should work just fine.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Links not working. all show homepage. Permalinks are set but will not work?’ is closed to new replies.
Skip to toolbar