Skip to:

No Blogs, No News, No Members, No Groups

  • joedecarlo


    I am having a problem with a brand new install. Here are the steps that I took:

    I downloaded the latest version of WPMU (2.6.5)

    I copied wp-admin, wp-content, wp-includes directories along with the files in the root installation directory to the root directory of my site.

    I installed the database with no problems.

    I followed the advice of the BP instructions and I created a new blog, created new posts and comments. Everything worked as expected.

    I then downloaded the latest BP zip file (r598).

    I copied all of the files and directories in the root directory of the zip to the /wp-content/mu-plugins directory.

    I copied the buddypress-home directory to /wp-content/themes directory

    I copied the member-themes directory to the /wp-content directory.

    I went to the Site Admin->Themes page and selected ‘Yes’ for the BuddyPress Home Theme and ‘No’ for all the others.

    Note: At this time the theme for the home page was still the default wordpress blog theme.

    I then went to the root blogs (located at / according the the manage blogs page) and change the theme for it to BuddyPress Home Theme.

    Now I get Error 404 messages when I select the News or Blogs from the home page. Also, when I go to my member’s page, it says that I have no blogs, to create one. After creating another blog, the member’s page still says that I have no blogs. If I select Members, it doesn’t any, not even the member that I am logged in as. However, if I put the Members Widget on the home page, it lists me there.

    I feel pretty confident that I installed WPMU correctly, but I suspect that I didn’t install buddypress to the right location(s).

    Please advise.

Viewing 17 replies - 1 through 17 (of 17 total)

  • bearuser


    Same problem here. I hope there is a solution.

    I am not even throwing errors, which has made it even more frustrating. (not that frustrating because bp is still being made, but intellectually frustrating…..because I have no friggin idea.)

    Any help would be much appreciated.


    I guess blogs is now kind of working. They still don’t show up on the “blog” page, but if I filter out “T” test blog shows up.

    Also, blogs are still be created as private after BP install.



    i’ve the same problem but only with “blogs” and “news” page… “groups” and “members” works fine!

    Are you both installing BuddyPress in the root, subdirectory or subdomain? There are problems at the moment if BuddyPress is installed in a sub dir. These will be fixed very soon.

    sub-domain. :(


    Although, I guess that is kind of a lie. I have an account at HostGator for and as an add-on domain my bp site ( is in a subdir of the public folder, does that make it a total lie? I just figured it would be ok because WPMU works fine, but I guess wpmu works in a subdir.

    Is that my problem?


    This really is an amazing system.


    I know shared hosting is no good. I will upgrade soon.



    my blog is installed in root but using a subdomain like and new blogs are created in subfolders…

    I have WPMU installed on the root and buddypress installed at /wp-content/mu-plugins.

    You can see the behavior by going to it:

    My last post distracted from the issue. After talking with support, mine is installed in root as well.

    Everything works on my site except for “My Blogs” and “blogs” page.



    hi bear. i’ve the same problem. Everything works fine except for “MY Blogs” and “blogs page”..

    Blos page works but not in the correct way, it opens without the list of all blogs.

    Hmmmmmmm. I wonder if that means that while mine is in the “root” according to HostGator support, that it is actually in subdomain. Question: can you have double subdomains (ie. If you can, then I might be in a subdomain, that wpmu works through and bp is just learning to (according to apeatling).

    @apeatling is that saying it right?

    Full disclosure, it is in a subdomain, but HostGator has said there is no difference because of the way they have it set up as an addon domain………I just know that magic happens in the form of a redirect and it is never seen as a subdomain.

    I have installed a fresh version of WPMU and Buddypress and I am getting the same issue. If I type in “/blog/news/” it works, but not “/news” as the link in the theme has it.

    Don’t know what did it, but just installed 610 and everything is good with “my blogs” and blogs.

    A couple of other issues still, but only things that I believe will be worked out shortly.


    I updated to that version and am still having the same problem. Could it be because I am using directories for the member blogs instead of subdomains?

    Upgrade to the latest trunk

    Thank you, Andy. This resolve my problems.

    Yes. It works now. Thanks!



    I’ve update to the last trunk but I still have the problem with “/blogs” directory page. I’ve a second problem with “blogs”, when a user create a blog, it doesn’t appear under user’s blogs list… The new Blogs are installed in a subdomain.

    thanks for your help!

Viewing 17 replies - 1 through 17 (of 17 total)
  • The topic ‘No Blogs, No News, No Members, No Groups’ is closed to new replies.
Skip to toolbar