Skip to:

Nothing appearing under "My Blogs"

  • Any thoughts as to what might make the main blog disappear under the “My Blogs” admin bar menu item in the front end? Also, in my profile the “Blogs” tab indicates “(1)”… but when I load that tab I get a “Sorry there were no blogs found” error. Within the backend, the main blog still shows up under “Site Admin > Blogs” and the ID is 1. If I tell the form to show results by IP… again… it’s still listed. But if I tell the form to show results by ID… I get “no blogs found”. Total mystery. I haven’t changed anything. It seemed to just stop working. All I did was add a new administrator to the blog at the bottom of the “Site Admin > Settings” page.

    WPMU + BP1.2 Final and no other plugins.

Viewing 25 replies - 1 through 25 (of 52 total)
  • IF: >> wp-admin >> Site Admin >> Options >> Allow new registrations >> Only user account can be created

    is chosen, you can not have blogs, the logic stand… this is a little flaw in WPMU, not buddypress… this will be corrected with WP3.0

    I see that it’s normal actually for the main blog not to be listed in directory or profile listings. So ignore that. But it’s very odd that it no longer shows up in the “My Blogs” menu in the floating admin bar at the to top of the screen. This is with no plugins and the final release of 1.2 and the default theme. Weird. Must be some odd database thing? In fact… I just updated another site to and 1.2 final with no other plugins and it’s menu works. I’m at a loss here. I’ve compared all the settings in the backend between the site that works and the one that doesn’t and they are the same.

    I am still on trunk and will check that as soon as I updated to 1.2…

    Two of my users having a similar issue (probably more, but not reported). Their blogs “disappeared” – meaning, not anymore under “my blogs” in the admin-bar and it shows (0) blogs in their profile and they are not listed anymore in the directory. BUT they are there – reachable through the url…

    Strange and not very good… :-(

    I guess it is not possible that it had something to do with the chosen theme in their blog, right?! They had the same theme… (by the way: the BP-Update to 1.2trunk broke those themes… strange also…)

    Any help would be appreciated!

    I will also come back to the issue as soon as I updated…

    It’s beyond me. It has nothing to do with the theme though. The HTML source shows the following:

    <li id="bp-adminbar-blogs-menu"><a href="">My Blogs</a><ul></ul></li>

    So there’s nothing under the “My Blogs” drop down menu. Just an empty ul. This is with no plugins and the final versions of WPMU2.9.1.1 (sub domain install option) and BP 1.2. But I have another site running the same versions and it’s fine. The only difference is the database (obviously) and that other install is a “blogs in a sub directory” install. One works. One doesn’t.

    So it has to be a database or configuration thing. But I can’t for the life of me think of what changed. Unless the client changed something. I even put the two dashboards up side-by-side for the two sites and went through every config screen to set them all to the same settings. One works. One doesn’t. Argh.



    David, are you running a custom BuddyBar?

    If so, I’d recommend commenting out your custom functions for the BuddyBar to see what happens.

    Thanks r-a-y.

    No there is nothing custom in either installation. No custom BuddyBar. No plugins. No child theme. Default theme. Release versions. On one site, the drop down is populated. On the other, it is not. I’m a WPMU/WP admin on both sites. It’s kind of driving me crazy. I’m about to try moving the site over to a fresh database to see if that solves it. Just as a test.

    Odd thing is it was working up until yesterday. And the only thing I can think of that I changed was that this morning I made the client a WPMU admin using the space separated list in Site Admin > Options. That and updating to 1.2 final. But I have other BP 1.2 final sites that are working fine.

    I just mirrored my live site with my local development copy of the site. I reinstalled WPMU and BP on both. No plugins other than BP 1.2. The “My Blogs” submenu is populated on the local site but not on the live. So it has to be something wonky in the settings or database. Ergh.

    Okay… it has something to do with using a subdirectory setup versus a subdomain setup. I’m on to something at least. LOL.

    After 8 hours of testing I officially have no idea why all of my blogs are no longer listed in the blog directories or menus. Nothing even changed. It worked one day and it broke the next. I’ve reinstalled everything from scratch. Brand new WPMU. Brand new BP. No plugins. Default theme. Brand new wp-config and htaccess. Nothing fixes the problem. And I have no been able to recreate the issue with any number of different test installs. They all work fine. The only thing I have NOT done is install a new database. So it looks like I have no choice. I have to start over with a fresh database and try to migrate the content over. I really want to curse right now… but I won’t.

    Fresh database fixed it. Still don’t know how it got bonked.



    Glad everything worked out for you, David!



    I have same problem. One of two blogs disappeared from “My Blogs” and BuddyBar.

    @ r-a-y: Well… it did… but only by brute force… by completely replacing the database. I imported the posts table so I didn’t lose any content. I didn’t dare import any other tables. Still wish I knew what happened but it was absolutely related to something in the database.



    Same issue occurred with us when we upgraded to 1.2… buddybar issues and my blogs disappeared… we eventually just downgraded.

    I hope you restored your database when you downgraded. If you’re using a database which has had BP 1.2 installed or upgraded to on it, and if you are then running BP 1.1.3, you will get errors and problems.

    Plus, if you’re finding bugs, I hope you are contributing them to

    Hey DJPaul. Thanks for chiming in. Just FYI… in my case… I had been running 1.2-bleeding (clean install of 1.2 bleeding) and I’d been updating the plugin every few days. Sometime around Sunday/Monday my Blog listings disappeared from the admin menu, profile page and blogs directory. No idea what happened there. If I had found the problem… I would have submitted a bug. But I didn’t want to submit a bug for something I couldn’t replicate.

    Had the exact same issue yesterday when I upgraded. Thought it was a browser malfunction at first (I was at work and using IE *gag*), but in the end I fixed it the same way as David with a fresh database. I checked everything I could think of and starred at code until the page got wavy and I have utterly no input as to what caused it, but there’s something in the upgrade that seems to randomly do this. No idea.

    @DJPaul: I don’t think it would be related to that ticket since I had not created any user blogs. I only had the main blog. It was the main blog that disappeared from my listings and menu.

    @Cyndy: Internet Explorer is just one big browser malfunction. LOL.

    I just upgraded to 1.2 stable…

    It is a real tragedy!!! :-( As described above, some user-blogs just disappeared. They are still there, but not anymore under “my blogs”, not in the directory etc etc…

    Can anyone help??? I think that should/could be a task for andy or some of the gurus… I cannot do, what some did: Just a fresh DB (Sorry I am just not good and brave enough for that!!!).

    Any help appreciated.

    PS. It runds on a subdirectories-install…

    It has nothing to do with the install type after all… but I’m afraid I don’t know what causes it. As I say, all I did was start over with a fresh database.

    What version did you upgrade from Michael? I noticed this happened on another site I had that was running trunk versions of 1.2. I hate to say so… but perhaps things like this are just the price we pay for playing with pre-repease software. I’d be interested to know if anyone has experienced this problem after upgrading from 1.1.

    I wonder what the best way is to debug this? Maybe make a fresh database and import the old tables one at a time till you at least know what table is screwing things up?

    @David – The site that had the issue for me was an upgrade from 1.1. Strangely, my test site worked fine when I upgraded it and it had a trunk from a few weeks ago. (And also, I completely agree regarding IE. I work for the state, though, and they seem to believe that’s the only browser we should ever use. It’s clear proof there is something wrong with their brains.)

    Before I mess with the DB, I hope someone could hunt the bug down…!

    I am kind of desperate here…!

Viewing 25 replies - 1 through 25 (of 52 total)
  • The topic ‘Nothing appearing under "My Blogs"’ is closed to new replies.
Skip to toolbar