Skip to:

Nothing appearing under "My Blogs"

  • Any thoughts as to what might make the main blog disappear under the “My Blogs” admin bar menu item in the front end? Also, in my profile the “Blogs” tab indicates “(1)”… but when I load that tab I get a “Sorry there were no blogs found” error. Within the backend, the main blog still shows up under “Site Admin > Blogs” and the ID is 1. If I tell the form to show results by IP… again… it’s still listed. But if I tell the form to show results by ID… I get “no blogs found”. Total mystery. I haven’t changed anything. It seemed to just stop working. All I did was add a new administrator to the blog at the bottom of the “Site Admin > Settings” page.

    WPMU + BP1.2 Final and no other plugins.

Viewing 25 replies - 26 through 50 (of 52 total)
  • @Michael: If you create a new database with a new name (don’t delete the old one) and then rename your wp-config.php file to wp-config-old-database.php and visit your site… WPMU will bring up the install screen again in order to create a new wp-config file that you can point to your fresh database. To go back to the old database… just swap your config files back (rename wp-config to wp-config-new-database and rename wp-config-old-database to wp-config). Point being… I wouldn’t mess with the database either. Not without a backup. So keep the old one on the server and for good measure… export a local a backup as well. And make local backups of those wp-config files too while you’re at it. Make a fresh database and then start importing just your content tables from the old to the new. I’m not sure if/when I’ll have a chance to debug this myself.

    Thanks David!!! Maybe I have to do that…

    But I still think and hope, that Andy should have a solution to this (alot of people having this issue, and maybe more didn’t find out yet…)

    I agree. Seems like a serious issue and there are at least three of us that have experienced the exact same thing.

    I just recreated this problem by accident!!!!!!!!!

    1. Logged out of the site

    2. Registered myself as a new user

    3. Activated the account

    4. Logged in as the new user. Blog listings disappeared

    WTH?!?!?!? This is a SERIOUS bug! I’m going to try to replicate again using a fresh install and if I can replicate it again… I’m submitting to trac. This is brutal!!!! My client needs to go live on Monday and unless I can find a fix for this… we’ll have to redo the entire database again. And the client just finished creating all his content.

    Okay… I fixed it. All I did was switch the order of the admin usernames list under “Site Admin > Options > Administration Settings: Site Admins” and the blogs listing magically returned. Very strange. This should be completely irrelevant. I’m still trying to reliably replicate this problem.

    Having exactly the same problem here having upgraded to WP 2.9.1 and BP1.2 last night. Blog associations not showing in the “My Blogs” drop down from the Buddypress Admin Bar, or through their profile pages. All blogs and user associations seem to be correct in the back end, though. Help!

    @David – didn’t help me. So we keep up the posting here until someone hunts the bug down!!! :-)

    The problem is that it seems to be random. I was hoping I’d be able to replicate it after I saw it happen again last night… but no dice. There’s no point creating a defect ticket if you can’t outline the steps to replicate the defect. If the developers can’t replicate it… they can’t fix it.

    I searched on the WPMU forums too but didn’t find anything related to this issue.

    With no user blogs at all, just the main blog, if you create a new user they have no blogs listed under “My Blogs”. That’s normal I guess since they did not create the main blog. So I log in as admin and make the new user an admin on the main blog. Now the main blog shows up under “My Blogs”. Also normal. The weird thing is that if I then REMOVE their admin privileges… the main blog STILL shows up under “My Blogs”. That doesn’t seem right.

    Can anyone here remember what they did just before they started seeing the problem of disappearing blog listings / menus? Also… what are your privacy settings?



    This has been random for us too on subdirectory and subdomain installs. It usually comes back after a while of rummaging around upgrades and other customizations. Currently we’ve had it happen again after we deactivated bp to create blog with just MU . We activated bp again afterwards and the main blog went missing from the admin bar and the my blogs listings. hoping to see it come back on its own but it would be great to avoid this from happening again.

    Roger Coathup


    Exactly the same problem for me.

    New install / site, WPMU, BP1.2

    Main blog is missing from My Blogs on site admin bar, and from Blog Directory listing (although the listing count shows 1).

    Like @david, I’m sure mine was working then ‘just disappeared’.

    Did this get entered as a bug?

    I have “lost” my blogs (on fresh WPMU with BP 1.2) when I configured the settings for the user role of new registered users. New settings to other roles haven’t brought them back. I gave up after 3 fresh new installations with wpmu.

    Because i need only one group blog I decided to change to WP with BP 1.2 (without MU-function). But there the blog modification links aren’ t shown in the horizontal admin/user bar. Not for me as admin and also not to other users (authors, editors etc). As work around i am using now the plugin “Mini Meta Widget” which offers a menu directly to the different admin commands like “new post / edit post / manage media …” – but this is only a bad compromise.

    still giving


    Ditto …

    not only do I “lose” blogs from the All Blog list, or have (1) blog showing in the navbar but NO blogs showing in the My Blogs list … but I also get random blogs show sometimes but not all.

    All blogs tab show (5) but only 3 listed.



    This is a serious issue! Its the weekend so everyone is probably relaxing hopefully when the week starts we will see a solution come out.

    I created a very unspecific ticket:

    still giving


    Priority just changed from ‘critical’ to ‘minor’ … “Not a critical-priority bug.”

    There was a similar problem with the last release not recognising blogs if they had been created before BP was installed. I had to rebuild the install to get them recognised. It is not the same problem/fix, is it?

    No, it isn’t the same! Because it happened to me with a fresh WPMU Installation+ BP 1.2 and new created blogs.

    For me and others it is a major bug and not a minor. With this bug BP 1.2 and WPMU isn t usable.

    Roger Coathup


    I’ll second it being a major bug as well (although perhaps not critical)… the workaround being to use /wp-admin… which is far from ideal for end users

    Roger Coathup


    @djpaul can you explain to us why you’ve downgraded this to minor in the trac system?

    It seems to be causing major headaches to a number of developers

    Roger Coathup



    the /wp-admin ‘workaround’ of course only fixes the problem of accessing the dashboard / adding stories.

    It does nothing to fix the problem of the Blog Directory not working.



    I concur it is indeed a major problem. My site is currently unusable much like the many others who are experiencing the same problem.

    Can anyone experiencing this problem deactivate BuddyPress, get a copy of the 1.2 branch from SVN then reactivate and see if the problem is fixed?


    @Andy: I have a backup of an old database that was having this problem (I solved it by creating a fresh DB). I’ll setup a test site now and report back shortly.

    @Andy: I can’t get my SVN client to work so I grabbed the zip file from here: I assume that’s the same? r2755

    Short story… didn’t fix it. Here are my steps:

    1. Set up a fresh host and database
    2. Installed WPMU
    3. Installed BP 1.2 stable
    4. Everything works
    5. Imported my broken database completely overwriting the fresh database – Blog lists are broken
    6. Installed BP 1.2 r2755 (Deactivate BP. Overwrite files. Active BP) – Blog lists are still broken

    Would it help if I sent you a mySQL dump of the broken database for you to test with? It’s only 980KB.



    had a similar problem with sub menu in “my blogs” because of a missing slash in the path.

    After reading this tread, it seems it’s more complicated

    anyway, i posted a ticket before i read here

    I have installed buddypress r2755 on a fresh WPMU and it works. Could add new users and also new blogs with success. All are listed in the blog directory and the blog functions in the admin bar working, too. It seems that for fresh WMPU installations the problem is solved, now.

    Thanks to Andy P.

    Hopefully there will be also a fix for the upgraders.

Viewing 25 replies - 26 through 50 (of 52 total)
  • The topic ‘Nothing appearing under "My Blogs"’ is closed to new replies.
Skip to toolbar