Skip to:

[Resolved] Activity Stream’s Post Comment Button Has a Broken Link

  • 1337h4nd said 1 week, 2 days ago:

    Hello, I run the site I’ve been experiencing a problem for a couple weeks now and am in desperate need of a solution.

    When members try to add a comment to recently posted activiy, the post button redirects to a 404 ‘Page Not Found’.

    I’ve tried resetting all permalinks, I’ve checked to see if the theme I was using was the problem, but I recieve the same error when using the bp-default theme. I’ve also tried to deactivate any plugins that might be messing up the link…

    I tried looking up similar problems that may have occured to other people on the net, the closest I came to a solution was this ticket:

    I haven’t altered any of the php associated to the activity stream or comments. I’m not even sure where the problem might be contained. Any help on this matter would be much appreciated – this has been a huge obstacle for members trying to communicate.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Profile photo of @mercime


    @1337h4nd WP/BP versions? What theme are you using? Linux/Windows hosting? Single WP or Multisitie? If changing to bp-default theme didn’t work, have you tried deactivating plugins except BuddyPress and resetting permalinks? I’ve seen two instances where that happened and both were due to themes which have not been updated to latest BP versions.

    Hi @mercime I have the same problem. WP 3.3.1 and BP 1.5.4. I’m using a child theme based off a Theme from (Gratitude – )

    You can see the live site with the errors here I de-activated buddypress plugins (which subsequently also weren’t working ) and then I reset permalinks. Still no go. Any help would be uber appreciated.

    But did you deactivate the custom theme and activate bp-default, disable all plugins except BP and for good measure visit permalinks page to clear cache.

    And are you really having exactly the same issue? It is proper to create a new thread and describe your issue in as much detail there rather than tag (hijack) on to an old thread.

    Profile photo of @mercime


    @cipes Hi there. The issue should be brought to the attention of your theme author who should be able to answer your question. Cheers.

    @mercime Well, testing the theme on it’s own on my local server shows that comments work without issues, so I don’t think it’s a theme issue.

    @Hugo, The problem described by the first poster, perfectly fit my situation, So i thought it would be fine to chime in with my voice here. I actually thought I was doing something good to keep forums threads to a minimum. I’ll be sure to start a new thread next time.
    I haven’t de-activated the theme, because unfortunately, the site is now live, and I didn’t test it thoroughly before launch. So I geuss I’ll get it setup up a dev server and then do the testing you suggest.

    In general, besides plugin conflicts and permalinks, are there any other culprits? server side things?

    If your theme works in full with BP running on your local dev then little point in testing just with bp-default theme, this points to some other issue but guessing at what that may be without everything to hand is too difficult – if your tests are not with custom theme and BP i.e just the theme and we’re talking about WP comments then the custom theme may have an issue with BP and that will need to be proven then taken to the theme author for a possible answer – if this is a theme that is intended to be BP compatible.

    @Hugo @mercime Thanks for your guidance. On a testing server I took down all plugins and gradually tested everything out the culprit was the Easy Mailchimp email subscriber plugin available here..

    And without that plugin, comments work like a charm. I guess if this was my own post, I could set it to resolved :-)

    Profile photo of @mercime


    @cipes cool. thanks for the info about the conflict with Easy Mailchimp plugin.

    Profile photo of jacklaws


    Thanks for the help.

    Profile photo of webwarrior.wng


    How could i flag my own post… using bpModeration plugin. Thanks

    @webwarriorwng I don’t see what this has to do with this post, please ask the question once only in the appropriate forum or group.

    Closing this thread as it was a resolved one.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Activity Stream’s Post Comment Button Has a Broken Link’ is closed to new replies.
Skip to toolbar