Skip to:

[Resolved] Cannot add a new forum topic in groups

  • WP 3.4.1
    Salutation Theme
    BP 1.5.6
    BBP 2.1.2

    When I go into groups, I cannot create a new topic within a group. When I click, it appears to do nothing. Tried reverting back to the buddypress default and I got the same response. I do not have buddypress templates active. However I did at one time but is has since been deleted. Any idea why I cannot create a new topic in groups?

    I’m a rookie, haven’t modified any code. This feature has never worked.

    Please help. Thanks

Viewing 11 replies - 1 through 11 (of 11 total)

  • Tammie Lister


    Hi queenieb, would you happen to have a link to see your site in action? Also do you have any other plugins active on your site? If you do, if they are removed does the issue still happen? I’m trying to see in saying that whether you have a scripting issue from a plugin or not.

    Sure @karmatosed
    Username/PW: tester
    Yes I do have other plugins active. The only BP one is Private BuddyPress.



    I thought that integrating BBP 2.1.2 meant you didn’t have group forums, but a sitewide forum. In order to have forums that are connected to specific groups, I think you need the bb-config.php (bbpress version 1) file in your wp-content folder. This should be automagically created when you enable forums for groups:

    Having the newer version of bbpress (the full plugin available through the repo, and activated through your plugins menu) will create forums separate from the groups you create.

    Perhaps I am not understanding what you’re saying. The codex tells me that I can have both. I followed the instructions to the letter.

    I went ahead and upgraded to BuddyPress 1.6/Salutation 1.5.1/BBP 2.1.2 and my WordPress is at 3.4.1. I also copied my bb-config.php file to my wp-content folder.

    I decided to fore-go the site-wide forums and just use the forums within the groups.

    I’m still unable to create a new topic inside of a group. Nothing happens when I click on either of the 2 ‘New Topic’ buttons.

    Also when I enter text in the “What’s New in ‘this group’?” activity box, there is no submit button and the comment just sits there.

    I tested this using the buddy-press default theme as I’m hoping to get this resolved soon so that I can try it with my Salutation theme.



    @queenieb You’re right. You can have both the sitewide forums and the group forums.

    As for the issue/s you’re encountering, I read that Salutation theme [edit] has been updated for BP 1.6

    Thanks @mercime. I just updated my Sal to 1.5.1 today. I hope 1.5.2 will be coming soon and my fingers are crossed as to whether this will fix the problems. I really don’t think my issues are related to Salutation. When I revert back to the BuddyPress default, I am still experiencing the same problems. That tells me that it’s not Salutation. Not sure where to go from here except BuddyPress…but these issues are holding up my launch. Hoping for a fix soon. Q!



    @queenieb I test every install with bp-default theme before activating other plugins or adding new theme. I was going to check out the issues in your site but the username/pw you gave above is invalid

    Found the problem. It appears that one of my plugins was the culprit. All is well now. WHEW – Finally! Thanks Guys for trying to help. Q

    @mercime, thanks for that suggestion. I will definitely test with the bp-default theme first from now on. I appreciate your help. Q!



    @queenieb glad you resolved it too :-) Marking this as resolved.

    @queenieb Which plugin was causing problems?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Cannot add a new forum topic in groups’ is closed to new replies.
Skip to toolbar