Skip to:

[Resolved] ”Post” Button Not Showing & Other Ajax Or JQuery Issues

  • I am working on a website called Bass & Format. You can view it here:

    Last night I installed the buddypress plugin ( and bbpress (2.0.2), as well as the buddypress template pack (1.2). I was able to setup my templates to work with my theme so that they appear correctly, however I am at my wits end with the following issues:

    1) The post button doesn’t show up on the activity stream. If I press tab and enter, it will make the post (the code is still there apparently) but nobody can actually see the post button.

    2) The members “Order by” dropdown does not work. It used to show the circling image but now it doesn’t even show that.

    3) When the activity stream was working, I tried to reply to a post and after I typed my comment and pressed post, it redirected me to the main page and didn’t post the comment. Directly after this the activity stream button disappeared completely. Before this, everything was working fine and I could at least make posts to the activity stream.

    4) When you are logged in as ADMIN and you go to you cannot see any of the activity updates. It says “Sorry, there was no activity found. Please try a different filter.” Using the dropdown doesn’t show the circle animation or do anything. However, when you are logged out you can see all of the updates, but the post button is gone and you can’t make comments replying to the current updates. Using the dropdown will show the animation but doesn’t do anything.


    – The activity stream was working 100% for about an hour and then it stopped. I didn’t install or change any plugins. One thing I may feel might have something to do with it is the option “Disable BP Template Pack JS / AJAX”. At some point or another I had checked that and pressed save because I wasn’t seeing the post button for activity streams. I unchecked it (enabling) and a while later the activity stream was working. Could this setting cause any issues? It can also be the sort dropdown that is causing the issue because I noticed my activity stream was working for a second, but after I tried to sort the results I got the error that there was nothing to show.

    – The dropdown animation was showing up for me logged in as admin until I checked that one option to disable the BP template Pack above. After that it stopped showing for me as admin but it seems like it shows for regular members and guests.

    – The ajax for favoriting an post works when you can actually see the activity. Also for deleting. Just not for commenting and posting.

    I feel like this may have to do with some kind of jquery or ajax or javascript error. I am willing to give login info to anybody who can help me out with this. I already have uninstalled many plugins and the problem still persists. Is there anyone who can help me???

Viewing 8 replies - 1 through 8 (of 8 total)

  • @mercime


    Enable JS by not checking the box and click on Save.

    I did do that, but it still doesn’t work. What I was trying to explain above was that I think the problem occurred after I had initially checked that and unchecked it. Maybe the setting doesn’t really clear? Either way, it seems like it works after logging out and closing the browser and then logging back in. It’s very weird, but there has to be some kind of issue going on with ajax, javascript, or jquery.

    Even though I did get the buttons to show up again after logging out, closing the browser, and logging back in, I still can’t use the comment feature (for commenting on activity) and I still can’t use the dropdowns that let you sort the member/activity feed. I ended up hiding the two with CSS and I may have to hide the comment feature on activities if I can’t find a fix to this problem. I really wish I knew more about jquery and java to see what is going on.

    Is there anywhere I can post this to try and get a solution? Maybe a bugs forum?

    Ok I am going to just try and see what I can do on my own. Thanks for mercime for trying to help

    roofer roofer


    I was having the post button problem. The solution for me was that the css had the button height a 0. I put this in the custom css section of my theme. voila.

    `#whats-new-options {
    overflow: auto;
    height: 40px;

    Thanks roofer! :D I really appreciate that you took the time to help me, it means a lot! Now if I could only find out about why I can’t reply to activity that’s posted… X_X



    I seem to be having the same issues. Did you ever find a solution? Thanks in advance for your help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] ”Post” Button Not Showing & Other Ajax Or JQuery Issues’ is closed to new replies.
Skip to toolbar