Skip to:

Stylesheet not loading for Default Member Theme

  • 2698507

    For example

    I have the bp-themes folder in the wp-content directory. It has the themes in there. I can see and select them in the BuddyPress General Settings. Page and content shows up, but stylesheet doesn’t load. Any thoughts?

Viewing 15 replies - 1 through 15 (of 15 total)

  • Jeff Sayre



    I assume you’re running BuddyPress v1.0. If so, please carefully read the section entitled “Upgrading the Theme files” on this BuddyPress Codex page.

    You need to move the home theme to wp-content/themes/ and keep the member theme in wp-content/bp-themes/ (bpmember)

    Check permissions on this file:

    it is returning a 404.


    Thanks everyone for the quick replies!

    @jeff I looked at the link you sent, but I’m not upgrading so I’m not sure it applies. I just downloaded BuddyPress this morning.

    @DJPaul the themes are in wp-content/themes/ and the member theme in wp-content/bp-themes/

    @andy the permissions on that file were 644. I changed them all the way to 777 with no change. What should the permissions be?



    which user and which groups have permissions ?

    permissions should be 755 and the users should be no root


    Permissions set to 755, still not loading. Not sure about users and groups. Using an FTP client to change permissions. Logged in with the original account I got from host, which is

    As per Andy’s comment, is returning 404. Usually if it’s a permission on the file system, you get a different error code sometimes.

    Does that file exist in that path when you look in your FTP?


    @DJPaul it does appear there…


    In addition to my CSS file not loading on Member profile pages

    – I noticed that the Newest/Active/Popular ajax links aren’t loading either on Members widget on

    – My images are uploading (I see them in the blogs.dir), but they aren’t displaying when called by a page.

    Could these all be be due to .htaccess issues? Here’s my current .htaccess

    RewriteEngine On

    RewriteBase /

    #uploaded files

    RewriteRule ^(.*/)?files/$ index.php [L]

    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$1 [L]

    # add a trailing slash to /wp-admin

    RewriteCond %{REQUEST_URI} ^.*/wp-admin$

    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule . – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $1 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $1 [L]

    RewriteRule . index.php [L]

    <IfModule mod_security.c>

    <Files async-upload.php>

    SecFilterEngine Off

    SecFilterScanPOST Off





    I have the same kind of problem with the ‘Members’, ‘Groups’ and ‘Blogs’ page. Its like these pages are not hooked up with the CSS. I only have this problem when using the latest Skeleton member theme thou. If I use the standard bpmember theme there\’s no problem. Why is that? Problems with the latest Skeleton theme on BP 1.0? :>


    I think the skeleton is an unstyled CSS file to use for reference when building a custom Member theme. So it should look like there’s no CSS.



    Anyone think .htaccess is the culprit to my Member themes display problem?


    OMG OMG OMG OMG! I fixed it!! I went back and looked at my error logs and I was getting

    SoftException in Application.cpp:544: Directory “/home/beerandb/public_html/wp-content” is writeable by group, referer:

    I was also getting that for the bp-themes folder. So I changed them from 777 to 755. I also found that I had an old “members-themes” directory in wp-content, which I deleted. And viola! It’s all better :-)

    I looked into this stuff further because of these two threads. Thanks everyone for your help with this! First time I used this forum for help and it totally paid off!!



    hey guys am having the same exact is what is in my error log..

    [Thu Jun 11 16:25:03 2009] [error] [client] (13)Permission denied: file permissions deny server access: /home/folder/public_html/wp-content/themes/bphome/style.css, referer:

    [Thu Jun 11 16:25:01 2009] [error] [client] SoftException in Application.cpp:252: File “/home/folder/public_html/wp-admin/themes.php” is writeable by group, referer:

    [Thu Jun 11 16:24:48 2009] [error] [client] (13)Permission denied: file permissions deny server access: /home/folder/public_html/wp-content/themes/bphome/style.css, referer:

    what permissions should i set ? coz i cant even see the thumnail for the theme

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Stylesheet not loading for Default Member Theme’ is closed to new replies.
Skip to toolbar