Skip to:

Unable to create groups or forums

  • carinallc


    I created a new install of WPMU+BuddyPress, and used the 1-click install for BBPress. I can point to the Forums page, but am unable to create Forums. Same for Groups – under Site Admin I get a No Groups Found without an option for creating.

    I’ve read the Codex several times, trying to glean something and reviewed the most recent forum entries on Groups & Forums. It appears that there isn’t anything that describes how to create Groups and/or Forums when creating a new install and using the 1-click.

    Any help would be appreciated.

Viewing 25 replies - 1 through 25 (of 25 total)
  • http://your site dot com/members/your username/groups/create/step/group-details



    Thanks DJPaul – did I miss this in the documents somewhere? And, any idea why I don’t have this as a direct link/url anywhere? I’m assuming it’s not meant that users type in this url in order to create a group?

    What theme are you using?



    I’ve created a custom theme off of the BP Default 1.1.1 I made modifications to the CSS file for colors, and removed the admin bar by adding a line to bp-core.php



    Ok, WordPress has the ability sometimes to make me feel really stupid.

    By disabling the admin bar, you lose the ability to create groups. Doh.

    Another change it would have been nice to have noted somewhere, and another reason why I’d pay good money (REALLY GOOD MONEY) for a technical deep-dive reference book on BuddyPress

    But, because the admin bar doesn’t fit the asthetics of the site we’re building, I need to find the code that makes up My Account, My Blogs, Notifications and Visit and make them part of our new header so that functionality stays intact.

    Thanks for your help DJPaul! Would you know offhand where I might find that code?

    I have done several installations this morning – all with defaults set, with the same problem over and over again – I can’t create groups.

    I installed in a subfolder with the blogs-create-in-subfolder setting at installation. Besides that everything is up to date and set to default. Really really frustrating.

    Any idea why I can’t create groups? I can create them as admin or an ordinary user.

    John James Jacoby



    Disabling the admin bar doesn’t change any functionality of BuddyPress. If you have groups enabled, and your theme gives you a path to the create groups pages, then you can create groups. What you’re looking for is in the userbar.php and optionsbar.php files within the bp-sn-parent directory.

    If you’re using a custom version of bp-default, click on your own profile, click on “Groups” and then “Create Group”


    Do you have groups enabled? What error message(s) do you receive? What is stopping you exactly from creating a group?

    Hi there, thanks for engaging with my problem. After I go to the buddypress

    Create New Group page, go through the process of putting in a group name, description, selecting options about group forum and comments etc, then upload an avatar, select users to invite and click Finsh… then I am redirected to the beginning of the process and if I go to the Groups page – there are still no groups created.

    John James Jacoby


    Odd, because in order for the avatar to upload correctly, it needs to be created by being provided a group_id. Is your avatar uploaded and displayed correctly? Technically the group is created after the first step, and the subsequent steps only serve to fill in the settings and options.


    Yeah I too have this problem.

    If I read you guys right the theme can make group creation problematic so how can I correct this.

    I don’t even have the option to create a group in any menu be it the bpress admin or the top navigation bar.

    I don’t have forums eighter even if all options are set to make it possible. why ?

    I am also not able to see the “create group” button. Also, when I click on the “groups” tab in my buddypress setup I am not able to get the groups directory- instead I get a “page not found” error (not a 404 but a buddypress formatted page not found).

    How can I enable the “groups” page and the “create group” button?



    I also do not have a create group link in my admin bar…



    Exact same problem as rsutaria ^^. I created a WPMU installation under, installed Buddypress, and chose the default template. Logged in as admin, I get a “Page Not Found -The page you were looking for was not found.” error when clicking the groups tab on the home page, and when navigating to members/admin/groups, I get what appears to be a page refresh and that’s all.

    Prior to installing Buddypress, I had added the line for the comments template into the default template’s Page.php file. I had also had Blog Templates and Toggle_Admin_Menus plugins active, but disabling those and removing/reinstalling Buddypress didn’t fix this problem. I went through and ensured that the WPMU settings allowed new users and groups to be created and that the Buddypress settings were defaulted.

    Any help would be great!



    Got pretty much the same issue here. Latest WordPress (non-MU) and BuddyPress installed via BuddyPress Template Pack Plugin.

    With nothing disabled in BP general settings, everything enabled in component setup.

    There is no “create group” in the “groups” tab. Only “My Groups” and “Invites”. Clicking the “groups” tab goes to which seems fine.

    But I want forums. And it seems forums are a property of groups. So I need groups. How to create groups?

    (After much confusion) I enter MANUALLY:

    This goes to /groups/create/step/group-details/images/images/bg_body.gif which looks good. The heading says “Create a Group” and there’s input fields for “Group Name” and “Group Description”.

    But entering group name, group description and pressing “Create Group and Continue —->” button only reloads blog homepage and creates nothing.

    I’ve read somewhere that this might be theme-related? I run Atahualpa, pretty extensively customized. Yet the BuddyPress Template Pack Plugin was supposed to integrate everything painlessly (for ignorant non-coders like me). And the weird thing is how smoothly it seemed to have done the job. Until it came to creating groups.



    I do have the very same issue, absolutely frustrating, even more to see there is no idea about the issue and how to fix it.
    No groups, then no forums, then useless WPMU site.
    Hope we get somethign soon.



    @dains – if your WPMU installation is installed under “groups”, there will be a conflict with BuddyPress. Either try installing WPMU under the root or re-define the BP Groups slug.

    Put this in your wp-config.php:
    define ( 'BP_GROUPS_SLUG', 'gatherings' );

    Change “gatherings” to whatever you want your groups to be called.

    @cpmrgmt – try this:



    I have BuddyPress installed with WordPress Single User with the BuddyPress plugin and I didn’t see the Create A Group button either.. so I Turned OFF: Let Users Create and Join Groups and TURNED IT BACK ON.. and the button now shows!

    Also.. the place where you see the button is: yourwebsite dot com/groups/

    You will need to create a link to that “Groups” page as it doesn’t appear in the Admin Bar normally.

    Scott B


    I am also unable to create any groups on my installation. Details:
    1. Ubuntu 10.04 fresh install dedicated to WPMU+BP only, on a corporate intranet.
    2. WP-MU 2.9.2, BP 1.2.3, + LDAP user authentication.
    3. Site blog uses BP default theme, user blogs use Kubrick.
    4. No other plugins enabled.
    5. From “groups” tab, click on “Create a Group”, which takes me to “site/groups/create/step/group-details/”. After entering Group Name and Group Description, clicking on “Create Group and Continue ->” just takes me back to /group-details/, Step 1, as if I had hit the refresh button instead of “Create Groups and Continue”.
    6. Have verified that after every attempt, the wp_bp_groups table in the MySQL database is empty.

    Any ideas?

    EDIT: forgot to mention, WPMU is set up for subdirectory blogs (“blogs.corp.lan/blogname”). User account authentication, blog creation, etc., work just fine, as well as BP user activity, mentions. But user private messages don’t work (separate issue, it appears).



    I was having the same problem. It was being caused by the javascript/ajax files for “BuddyPress Theme Compatibility” plugin.

    I solved the problem by going to Appearance > BP Compatibility, then scrolling down to the bottom of the page and clicking “finish”. That step only has to be done after you first activate the plugin. On the page that comes up, check the box for “Disable BP Template Pack JS / AJAX” then click “Save Settings”.

    That solved the problem for me.



    So, i have the same problem here. Using WP 3.0.1 and BP
    Everything works fine – but there is no “Create Group”-Link. Its no problem to create a group manually by using the url. I did every tip in this topic, even using a different template. But nothing works. I dont have starting point for thinking about the problem.
    What can I do?



    next try

    Too much confusion here…..
    No I found this: <—-no create link <—there is a create link

    I dont think that this behavior is logical.

    So, how do i get the link into

    open wp-content/themes/premiumnews/groups/index.php
    Search for:

     <a class="button" href="”>


    copy it (or copy it from here ;-) )

    now open


    and paste the code wherever you need it
    I removed the `

    ` tag and the “ and put the code after “

    Now everything is fine and logical.

    Happy weekend, happy group-creation!



    Thanks! Sorry I didn’t reply sooner, I don’t have email notifications on for this site. That’s a neat piece of code for the library.


    I seem to have the same problem, not able to create groups.

    I followed the steps above and now have a piece of code that looks like this.

    `  <a class="button" href="”>`

    This, however, only results in a 404 on the groups part of buddypress. Does anybody have an idea of what I did wrong?


    @vus firstly you should not re-open threads that are old especially ones that are two years old it is very unlikely they will be relevant to your issue – especially where code is concerned.

    Please start your own thread on your issue – rather than tagging on to end of another – even if similar to your issue.

    In the new thread describe and detail your present install in as much as possible, theme in use plugins etc.

    The aim is to identify why the issue is occurring as it shouldn’t so you do not want to be throwing code into the template files at this stage so remove the code you have added for the moment, until members can have a think and make a few suggestions to resolving your issue.

    I’m closing this thread as it should by now be read only really.

    Sorry about that, will follow your suggestion

Viewing 25 replies - 1 through 25 (of 25 total)
  • The topic ‘Unable to create groups or forums’ is closed to new replies.
Skip to toolbar