Skip to:

Unable to post new group forum topic

  • Profile photo of pearl_123


    Hi to all,

    I have group forum active but when i am trying to post a new top i am getting this error “This group does not have a forum setup yet.”

    Any help ?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Profile photo of modemlooper


    You should give more detail on your install, what plugins, what theme, versions… etc.

    Profile photo of pearl_123


    Thanks for reply,

    I am using Frailespatique Theme 1.2 from theme forest.

    Wordpress Version 3.2.1

    BP VERSION 1.5.1


    BuddyPress Admin Bar Mods
    BuddyPress Community Stats
    BuddyPress Member Profile Stats
    Buddypress Sidebar
    Buddypress Widget Pack
    BuddyPress Template Pack
    BBpress Latest Discussions


    Profile photo of @mercime


    Not to seize this topic, but I’m having the same issue – one variance – everything WAS working – until I moved to a new server two days ago. Now the topics that were working, are no longer visible or seemingly, associated to their appropriate Groups.

    It seems to not be a plugin conflict issue – AND – @mercime – in my instance – groups are enabled… “groups” and “group” creation are working fine.

    Creating new topics? Not working.

    Profile photo of @mercime


    @stjack you mean you had the same plugins, same theme and same BP/WP versions and configuration before you moved to new server with same or better configuration? Then something could have been lost in the migration to new server – import of database or incomplete theme file uploads to server. Have you also tried changing to bp-default theme and check if behavior is corrected?

    Profile photo of @mercime


    From your post here, go to admin dashboard menu BuddyPress > Forums > Forums for Groups – click on Use existing installation. In next panel, confirm location of your bb-config.php

    I had this problem and have finally solved it.

    Here’s what I did:

    1. deactivate all plugins except buddypress
    2. change theme to default
    3. backup your bb-config.php file
    4. delete bb-config.php
    5. backup /public_html/wp-content/plugins/buddypress/bp-forums
    6. rename /public_html/wp-content/plugins/buddypress/bp-forums
    7. download the latest version of Buddypress
    8. upload new version of /public_html/wp-content/plugins/buddypress/bp-forums
    9. upload rest of the latest version buddypress files
    10. go to your dashboard >Buddypress > components >forums click to install group forums and it will create a new bb-config.php file
    11. create a new group – DO NOT SELECT ENABLE DISCUSSION FORUM
    12. save the group
    13. go back into the group and select enable discussion forum
    14. create a new topic for your new forum
    15. If it works – check the other groups.
    16 If the other groups don’t work – de-select enable discussion forum and save – then select discussion forum and save again – see if that helped.
    17. change to your custom theme – double check again. You may need to redo step 16 for some of your groups
    18. reactivate your plugins and check again – you may need to redo step 16

    I know that seems like a lot of steps – and possible you could skip some of them – but that’s the exact process I used and it worked… woot!!

    Good luck


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Unable to post new group forum topic’ is closed to new replies.
Skip to toolbar