Skip to:

Updating to WP3.4 -BuddyPress causing problems

  • richardpd


    I have just tried to update my WP/BP blog to latest WP3.4 version but cannot due to these errors:

    Warning: require_once(BP_PLUGIN_DIR/bp-themes/bp-default/_inc/ajax.php) [function.require-once]: failed to open stream: No such file or directory in /home/xxxxxxxx/public_html/ on line 4

    Fatal error: require_once() [function.require]: Failed opening required ‘BP_PLUGIN_DIR/bp-themes/bp-default/_inc/ajax.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/xxxxxxxx/public_html/ on line 4

    I have had similar problems before when updating to new WP version & I have had to disable all plugins but this time I was not able to disable plugins as the buddypress error message prevented this! I tried to get round this by renaming the plugins folder but that did not work!

    So instead I temporarily renamed rdbloganimass_bp/bp to rdbloganimass_bp/_bp which allowed me to update my site to WP3.4 but has left a new BP error message on my homepage and this disrupts the site layout (even after renaming back to rdbloganimass_bp/bp):
    Warning: include(/home/hilaryd/public_html/ [function.include]: failed to open stream: No such file or directory in /home/hilaryd/public_html/ on line 3

    Warning: include() [function.include]: Failed opening ‘/home/xxxxxx/public_html/’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/xxxxxxx/public_html/ on line 3

    I will keep trying to fix this but meanwhile I am grateful for any help and advice to fix this

Viewing 4 replies - 1 through 4 (of 4 total)

  • modemlooper


    You didn’t say if you updated BuddyPress. New version out to fix 3.4 issues



    Hi-thanks modernlooper for your reply
    (I have now updated to latest BuddyPress & bbPress plugins-my site runs both plugins!).

    Thankfully I have fixed the problem now but it was a bit tricky..
    I now think the problem was an issue with x2 specific plugins-Wp Article Fetch & Tweet this.
    On deactivating both of these from Network Admin (my site is running WP multisite) my blog (running WordPress & BuddyPress) is back to normal.
    The Tweet this plugin is somewhat old & not updated so there could be some code issue with it. As for the WP Article fetch plugin I haven’t used it much so disabling it is no great issue!
    (I will look for a new ‘Tweet this’ plugin as Twitter plugins are quite useful)

    I still though need to get BuddyPress forums working properly on my site (I have posted several times for help with this on the support forum here but still BuddyPress forums are not running well on my site! If I wasn’t so stubborn to try & get BP forums working I would have deleted it ages ago & used an alternative eg Vanilla plugin or other-so if anyone can help me I would be grateful-but I don’t really expect any response as sadly I have had such limited response in the past from here to help me with this! I think BuddyPress is a misnomer; it could be better called somethingelse but I won’t type it now!..:-(…).



    @richardpd please start a new topic with the forums issue. If I recall, you had group forums already working and sitewide forum was problematic.



    Mercime-many thanks again for your reply.
    I still cannot get the hang of running BuddyPress group & sitewide forums together on my blog.
    So for now I have disabled BuddyPress Group forums and am using bbPress forums. I even made a child theme of my BuddyPress enabled WP theme anIMass and use bbPress 2010 forum style with it-see my post today on my blog at

    I will keep trying with BuddyPress but for the moment am using bbPress forum! Many thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Updating to WP3.4 -BuddyPress causing problems’ is closed to new replies.
Skip to toolbar