Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress 1.5 compatibility for plugins and themes

  • Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    Please let us know here of any compatibility issues or plugins / themes that work already for BuddyPress 1.5 during the pre-release phase. That way we can make sure people know when they can upgrade and update the codex with a list.

Viewing 25 replies - 26 through 50 (of 105 total)
  • Avatar of Michael
    Michael
    Participant

    @fanquake

    @foxly I vote for cake :)

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    @foxly Thanks so much for the kind words! Means a lot coming from a seasoned dev like yourself. Looking forward to seeing you in the dev chat!

    Avatar of foxly
    foxly
    Participant

    @foxly

    @boonebgorges You’re welcome … :)

    We’ve thrown some resources your way!

    1) Our testers are currently checking every BuddyPress plugin with > 1000 downloads. Our throughput is about thirty a day. Thus far, 85% fail (as in cannot be used) rate.

    http://code.google.com/p/buddypress-media/wiki/DOCS_BP_OnePointFive

    @karmatosed …email me [CarlRoett] -at- [Gmail.com] and we’ll give you write access to the spreadsheet and wiki.

    2) Our core devs are currently building a wiki to help other developers transition their plugins. Estimated finished in 2 days.

    http://code.google.com/p/buddypress-media/wiki/DOCS_BP_FixingPlugins

    3) OurSIGINT guys are doing their best to contact everyone with incompatible plugins and give them a “heads up”. We didn’t know about 1.5 until we stumbled across it in the forum, and we suspect the situation is similar for many other developers.

    http://bit.ly/gfIVw2

    Hope this helps get things rolling!

    ^F^

    Can you tell we really, really want 1.5 released to production… :)

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    @foxly I can’t say “thanks” enough for the effort you guys are putting into 1.5 compatibility. This is a *huge* help to the community (and benefits you too, since it gets 1.5 out sooner :) )

    It’ll be great to get @karmatosed write-access to the google doc. She has stepped up and taken a leadership role with a 1.5-compat codex page and with this forum thread, and it will be great for you to combine your resources – BP Media checking compatibility in-house, and @karmatosed (and others) collecting reports, etc from the forums.

    Again, thanks so much.

    Yes, applicable information does need to get to the codex; thanks for helping!

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    @foxly Awesome stuff :)

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I’ve just released 0.5 of BP Group Management, which is fully 1.5 compatible (it already was, btw, but I cleaned up some PHP warnings and other small issues :) )

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    @foxly – Any chance you kind folks can test the plugins with menu issues against this patch?

    https://buddypress.trac.wordpress.org/attachment/ticket/3454/3454.patch

    Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    @Pisanojm: Oh sorry about that updated now :)

    @foxly: It’s on the happy list now :) I sent you an email thank you that rocks would love to get access and get the codex reflecting it. *High 5 for doing that job really rocks seeing community all working together.

    Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    I’ve just done a mass update off the back of @foxly ‘s cracking list will add in links tomorrow but anything anyone thinks should be added or issues just add to this thread. Keep em coming :)

    Avatar of Michael
    Michael
    Participant

    @fanquake

    @boonebgorges NO worries, I’ve just updated it.

    @johnjamesjacoby We can probably do that for you :)

    Doing a test run for child theming and couldn’t figure out why some style rules displayed and others didn’t until I realized that BP Default is loaded after the child theme instead of before. Anybody else getting this or did I just botch my install?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @suchaqd no, you didn’t both your install. http://buddypress.trac.wordpress.org/ticket/3389

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @suchaqd no, you didn’t both your install. http://buddypress.trac.wordpress.org/ticket/3389

    Avatar of foxly
    foxly
    Participant

    @foxly

    @johnjamesjacoby

    We’ve modified our BuddyPress test install with your patch and deployed it to our testers. There could be up to a 24 hour delay before they cut over to it though.

    Thanks!

    ^F^

    Avatar of foxly
    foxly
    Participant

    @foxly

    68 plugins tested + 224 plugins in the work queue. Test team on fire!

    http://code.google.com/p/buddypress-media/wiki/DOCS_BP_OnePointFive

    @DJPaul
    Sorry for the contact message yesterday. The tester didn’t know you were a core dev.

    ^F^

    :D No harm. Thanks again for your testing; 1.5 has had the best beta period (in terms of community involvement and bugs found/fixes) to date of any BuddyPress release, and your team’s contribution is icing on a yummy cupcake.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    BuddyPress Group Email Subscription 2.9 has just been tagged, and is fully compatible with BP 1.5.

    Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    Cool updated it and thanks to the list from @foxly have now updated a lot of plugins to their current status.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I’m not sure if it’s good to fail a plugin purely because it has PHP warnings revealed with WP_DEBUG. Those warnings, if output to HTML rather than a log, can also cause problems with the rest of the plugin. We’re checking for BP 1.5 compatibility, not whether a plugin meets WordPress’ coding standards. Thoughts?

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    I kind of agree with @djpaul. The average user will (or at least should!) have WP_DEBUG disabled, and will (or should!) have error reporting turned off. In that sense, those plugins are in fact compatible with BP 1.5. (To put that another way, if we go by the strict standards, they were never compatible with any version of BP ;) )

    Avatar of Tammie
    Tammie
    Moderator

    @karmatosed

    Will get that sorted trying to get the spreadsheet to work in the page to save time currently but will get it marked as not fail because of those.

    Avatar of Tosh
    Tosh
    Participant

    @xberserker

    Hi, I’m the creator of the CubePoints Buddypress Integration plugin. I updated my test site to WP 3.2.1 and BuddyPress 1.5 Beta 2.

    I moved the admin menu to be under Cubepoints a few versions back so that still works. The items in the BuddyPress Admin menu are still there but when I go to the cubepoints pages on the front end (profile) I get “Page not found”.

    This is what I have for the link

    $cubepoint_link = ($bp->displayed_user->id ? $bp->displayed_user->domain : $bp->loggedin_user->domain) . $bp->cubepoint->slug . ‘/’;

    Based on this I tried this…

    $cubepoint_link = bp_get_root_domain() . ‘/’ . $bp->cubepoint->slug . ‘/’;

    This is the result:

    My Account > Points = http://test.mysite.net/members/xberserker/logs/

    Which is correct URL wise but still shows “Page not found”

    If I go to

    My Account > Points > My Points (anything in the submenu) = http://test.mysite.net/logs/points/

    What do I need to do? Here is my file so far. What I changed is line 131

    http://pastebin.com/2vJr4U23

    Also on my site site I get redirected to my home page when I tried to navigate to the activity streams for myself or the global one. On how the forums work now. If a group is private/hidden are the forum topics only visible to those in the group?

    Avatar of foxly
    foxly
    Participant

    @foxly

    @djpaul
    @boonebgorges
    @karmatosed

    FAIL = “Does not run on BuddyPress 1.5. No workaround available.”
    MARGINAL = “Plugin works well enough to be used. Workarounds may exist for broken functionality. Or, all plugin features work but the plugin has huge numbers of debug errors indicating it will likely break in the near future unless it is updated.”
    PASS = “All plugin functions work on BuddyPress 1.5″
    PASS + “Excellent” = “High quality code. In the tester’s opinion, other developers can use this plugin as a working example to study when fixing their own plugins”.

    If you think you’ve found a mistake in the list, contact us and we’ll fix it. Probably within a few hours.

    Other status levels:

    SCRAPING = “BP-Media Team has been sent the URL of a plugin that somebody wants tested.”
    QUEUED = “A snapshot of the plugin info and files has been pulled and is waiting in the test queue”
    SENDING = “Plugin test package is being sent to a tester via Skype”
    TESTING = “Tester has acknowledged receipt of the test package”

    Thanks!

    ^F^

Viewing 25 replies - 26 through 50 (of 105 total)

You must be logged in to reply to this topic.