Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress Links 0.2-RC1 now available

  • Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    Hello All,

    BuddyPress Links version 0.2 (RC1, unstable) is now available for download!

    http://wordpress.org/extend/plugins/buddypress-links/download/

    (Don’t forget to re-copy the “links” folder into your theme!!!)

    * Added support for auto-embedding of rich media (API documentation coming soon!)

    * Reduced create/admin form to one page

    * Wider selection of thumb sizes for the links widget

    * Many CSS improvements and fixes

    * Lots of general refactoring

    * Some minor bug fixes

    Currently supported rich media services are YouTube, Flickr (Photo & Video), and metacafe.

    The rich media embedding is scalable to an infinite number of rich media services by extending the class API. I will be writing some more extensions based on Alexa.com reach statistics when I have the time. I am also going to try to write up some basic documentation for how to write custom services. In the meantime, if you are a PHP OO wizard, you will have no trouble figuring it our by yourself, just look at the class interfaces in bp-links-embed-classes.php. Feel free to contact me if you need help or would like me to check your work.

    Please post any bugs or other issues to this thread. I will do my best to monitor it and address anything that comes up.

    Enjoy!

    Marshall

Viewing 25 replies - 1 through 25 (of 60 total)
  • Avatar of Bowe
    Bowe
    Participant

    @bowromir

    I think many people have no idea how extremely full featured and well programmed this plugin is.. I’m just starting to grasp the amount of possibilities this plugin can mean for almost any buddypress site.

    I would go as far that this plugin is the best 3rd party plugin I’ve seen so far and that it only looks to become better and better. Expect a post about this plugin on BP-Tricks.com sooner then later!

    Great work Marshall!

    Avatar of cynthiablue
    cynthiablue
    Participant

    @cynthiablue

    RC1 Unstable… I really want this on my production site. Though I’m hesitant to install because of the ‘unstable’ bit. ;)

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @cynthiablue

    I think you are smart to hold off on using it for production yet. This version has only been tested by 2 or 3 people so far. Try it out on a test install first and play around with it, report bugs, etc.

    If enough people test it out, it shouldn’t take long to tag it as stable!

    Avatar of Lsm_267
    Lsm_267
    Participant

    @lsm_267

    i just installed it fine on my wpmu 2.8.6 + BP 1.1.3

    but can’t get it to work

    there is no page at http://myexample.com/members/admin/links/create/step/link-details

    could it be that the plugin doesn’t support the 1.1.3 release ?

    in any case I will follow what seems to be a very nice plugin

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @Lsm_267

    Did you remember to copy the “links” directory into your theme?

    Avatar of Lsm_267
    Lsm_267
    Participant

    @lsm_267

    i was just about editing my post to say I have been posting too fast.

    forgot to move the /links in the theme directory. now it works perfectly.

    indeed a very useful plugin and perfect integration job

    what bowe said above is realy the truth : not every plugin for BP is so well developped

    thanks

    Avatar of Jake Spurlock
    Jake Spurlock
    Participant

    @whyisjake

    I am seeing a small error in Safari 4. Looks like you need to add a clear or perhaps just some shifting around in the loop. I am getting steps down the page with content. Looks great in Firefox 3.5 though.

    You can see a screenshot here.

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @Jake

    Thanks for the report. That is wierd, I always thought Safari and FF were supposed to render the same?

    I would appreciate if you could submit a patch to fix any Safari issues, as I don’t have access to a Mac right now.

    Safari is available for PC. Has been for years. Or you can also test with Chrome. Chrome uses the same rendering engine as Safari (Apple’s Webkit Engine).

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    I need the interface and theme gurus to step up to the plate and submit some patches. I am 95% coder and 5% designer, so rely on the community to bail me out when it comes to these strange browser quirks.

    Avatar of pimpmywordpress
    pimpmywordpress
    Participant

    @pimpmywordpress

    Thanks for this awesome plugin. So far I have one issue when I save my link I’m redirect to the homepage without saving anyting, very strange any idea?

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @pimp

    Can you please provide some more information about your issue…

    Are you able to create any links at all, or does it happen all the time?

    Does it occur on create/admin or both?

    Is there a specific kind of data that causes this?

    Avatar of pimpmywordpress
    pimpmywordpress
    Participant

    @pimpmywordpress

    Thanks for the quick reply. It’s when I’m loged in as admin in my profile page –> under create a link. I tried several times with links and youtube videos links, same result. Running the latest version of MU & BuddyPress.

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @pimp

    Can you please post a couple of the links you are trying to add? I just want to make sure I am using the same data as you when testing.

    Avatar of Tore
    Tore
    Participant

    @toregus

    Would love to see this with 1.2 and some way to add the “link” on the frontpage.

    Avatar of pimpmywordpress
    pimpmywordpress
    Participant

    @pimpmywordpress

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @Tore

    Once 1.2 is considered to be more stable I am going to start a new branch of links to begin supporting the new default theme. I also have plans to do a lot more with the activity stream, but until it is on more solid footing, I am afraid to spend too much time on it.

    If you want to help update the theme to work with 1.2, that would be awesome.

    @pimp

    Thanks, I will see if I can replicate the problem.

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    @MrMaz, Job well done so far, can you provide screen shoots of it and for activity stream enable it so that when a user adds link or media it hookup to their stream!

    Maybe add a tag feature…

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @pimp

    Try deleting line 468 from bp-links.php

    remove –> “return false”

    That won’t solve your problem, I don’t think, but I want to see if you at least get an error message.

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @Gpo1

    You are the first to report a problem with links not being added to the activity stream. It works in my test install. The activity entries are showing up everywhere that they are supposed to.

    I am not sure how to go about debugging this one, hrmmm.

    Avatar of pimpmywordpress
    pimpmywordpress
    Participant

    @pimpmywordpress

    Yes I got an error message “Please fill in all of the required fields”

    Avatar of Tore
    Tore
    Participant

    @toregus

    @ MrMaz: I’ve got some basic CSS-skills but not more than that. I’ve got more opinions than skills (blushes)..

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @pimp

    make sure you have selected a category? the only req fields are category, url, name, desc.

    Avatar of pimpmywordpress
    pimpmywordpress
    Participant

    @pimpmywordpress

    I got this error after deleting line 468 from bp-links.php and remove –> “return false”

    I did select category and add url, name, desc after submit got this error “Please fill in all of the required fields”

    Avatar of jivany
    jivany
    Participant

    @jivany

    Hey, I know it’s in the instructions but is there anyway to programmatically detect that the “links” directory hasn’t been moved/updated. By default it should be put in bp-sn-parent (or bp-default in 1.2+) so any child theme can make use of it. Even if you don’t automagically move/update the “links” directory, make one of those nifty info bubbles appear at the top of the plugins page telling the user to move/update the directory.

    I’m a big-time “Add new” plugin sort of person and seldom manually install anything if I can help it. ;)

    Fantastic plugin and fantastic rationalization too. Made me double think media sharing in my current side project. I’m looking forward to your updates for the new 1.2 bp-default theme.

Viewing 25 replies - 1 through 25 (of 60 total)

You must be logged in to reply to this topic.