Skip to:

Avatars aren’t shown after the upgrade

  • Ali Erkurt


    Hi. I know there are other topics about that issue but this is new. Because I tried everything to solve that avatar issue but it still has a problem.

    I’ve upgraded to 1.2.5 from and now some of the group and member avatars are gone.

    I tried to fix with .htaccess but it didnt work.

    How can i solve that? thanks.

Viewing 5 replies - 51 through 55 (of 55 total)

  • Ali Erkurt


    @ronia I’m not sure but there’s one more thing… Are you using BP Groups CSS plugin?



    No only WP and BP nothing else.

    Ali Erkurt


    OK. I thought BP Group CSS plugin may cause the problem but I was wrong and you confirmed that…



    Hmmm…Ronia, the link to my site is

    Feel free to check it out.

    My bp-custom file is placed in wp-content/plugins.

    Let me post the entire code just for you…other issues could be you .htaccess file. Did you copy in the Multisite codes? It could also be an issue in wp-config.php…so many possible issues.

    Take a look at this code again.

    function nfm_bp_avtar_upload_path_correct($path){
    if ( bp_core_is_multisite() ){
    $path = ABSPATH . get_blog_option( BP_ROOT_BLOG, 'upload_path' );
    return $path;
    add_filter('bp_core_avatar_upload_path', 'nfm_bp_avtar_upload_path_correct', 1);

    function nfm_bp_avatar_upload_url_correct($url){
    if ( bp_core_is_multisite() ){
    $url = get_blog_option( BP_ROOT_BLOG, 'siteurl' ) . "/wp-content/uploads/";
    return $url;
    add_filter('bp_core_avatar_url', 'nfm_bp_avatar_upload_url_correct', 1);

    You may need to adjust the $url = get_blog_option( BP_ROOT_BLOG, 'siteurl' ) . "/wp-content/uploads/"; } to show your full address instead of ‘siteurl.’ So use instead. That may fix your issues…if not, I would suggest contacting Automattic and Buddypress support and see what they have to say.

    John James Jacoby


    @bennadler The problem with doing it that way (in BuddyPress core) is for installs where /wp-content/ is moved out of the WordPress root and located somewhere else, which is a common configuration for the more security minded folks.

    That fix will work for most everyone else however.

Viewing 5 replies - 51 through 55 (of 55 total)
  • The topic ‘Avatars aren’t shown after the upgrade’ is closed to new replies.
Skip to toolbar