Skip to:

Newbie, BuddyPress Installation Problems!

  • Stephen Farr


    Hi, I am completely new to WordPress and Buddypress. When I tried to install the Buddypress plug in, I received the following error:
    Unable to create directory /home/a6739716/public_html/teenchatww/wp-content/uploads/2010/07. Is its parent directory writable by the server?

    I have just noticed I can’t install any other plug in’s or themes. And I can’t upload any content…

    Can anyone help?

Viewing 10 replies - 1 through 10 (of 10 total)
  • It’s one of or a combination of two issues: the folder permissions may not be set correctly (these can normally be corrected via a decent FTP client folders generally need 755 and files 644)

    Check the WordPress codex for the correct permissions required

    The other issue and more likely the problem here is that the server group hasn’t got the correct permissions to create and write to directories, if you are on shared hosting you may need to contact your host to get this sorted out and also ensure that PHP ‘Safe Mode’ is turned off.

    What are the directory permissions on wp-content/uploads/?

    EDIT: beaten, once again.

    I only ever seem to get this issue on one server that I manage through Plesk or at least have the option of, other servers I administer via SSH never give me this issue, leading me to think something in the way Plesk deals with groups isn’t the best.

    Stephen Farr


    Thanks for the advice! I changed the file numbers to 755, and it gets past the uploading stage and uploading media works, but the plug in install stops halfway through. It gets to:
    Unpacking the packageā€¦

    Installing the pluginā€¦

    And it then stops loading. Any help??
    Thanks again!

    So you can upload, I presume, through the WP interface, (media library) and now you are trying to install the BP plugin but it’s not finishing? Can you upload the plugin via FTP and get it installed that way?

    Stephen Farr


    Already tried that, but it didn’t work…

    Raul Fenossi


    If your host have control panel, enter to your file manager browse to the indicate directory and set the persmissions to 755 or 775 whit this permissions are not critial.
    Or you try changin permissions whith your ftp client e.g. Filazilla

    @teenchat what didn’t work? did you manage to upload the BP files manually via FTP? Did BP simply not want to activate? We need fair bit of detail in order to help effectively,. What exactly didn’t work?

    Sidenote: To avoid memory issues ensure that PHP mem limits are as high as you can get them i.e 64MB or higher.

    Stephen Farr


    Right, sorry, I uploaded via FTP, and it appeared on the list of plug in’s, so I clicked install, and then it said it was missing a vital component. Everything except plug ins and themes are working fine.

    Arx Poetica


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Newbie, BuddyPress Installation Problems!’ is closed to new replies.
Skip to toolbar