Skip to:

Unable to post on my website in forum discussion

  • gen-superman


    Currently using:

    WPMU 2.7.1

    BBPRESS 1.0.1

    BPPRESS 1.0.2

    BPDEV Core 0.3

    WPMU bbPress Integration 1.0

    BBPRESS BuddyPress Support Plugin v1.0-RC1

    Well, I am about to throw my arms up, I am now so baffled and confused.

    I had all the group forum discussions working great and then suddenly, it just stopped working after I updated to BBPRESS 1.0.1.

    Basically, I have followed all the directions about trying to get the forum discussions to work in groups, and I had it working, and was able to previously post before. But, when I updated the BBPRESS to 1.0.1, I found that I was unable to make any new posts in the existing forum discussions in any group created, even in new groups created.

    So, I decided to start from scratch, New SQL Databases, new usernames, new passwords, the whole 9 yards.

    – I installed the WPMU 2.7.1

    – I installed the BBPRESS 1.0.1

    – Everything works fine at that point.

    – I went into the wp_config.php and the bb_config and placed in the following as normal (Keep in mind, that I have now done this 30 times.)









    define( ‘COOKIE_DOMAIN’, ‘’ );

    define( ‘SITECOOKIEPATH’, ‘/’ );

    define( ‘COOKIEPATH’, ‘/’ );











    define( ‘WP_AUTH_COOKIE_VERSION’, 1 );

    – All of that worked fine, I was able to remain logged in from either WPMU and BBPRESS, so all the settings were correct in those two files.

    – Next, I installed the WPMU BBPRESS Integration Plugin, and I set those settings up with:

    bbPress URL :

    Your plugins URL :

    Wordpress type : WordPress MU

    – I then took the manual settings listed on that page and inserted them properly into the wp_config.php and the bb_config.php file.

    – Next I installed the BBPRESS – BuddyPress Support Plugin made by Andy Peatling, and I placed that file in the bb-plugins folder, although I have also tested in the bbpress’s my-plugins folder too, but it seems to mostly work in bb-plugins folder. I don’t believe there are any settings that I can see for this plugin.

    – In BBPRESS, I go to WordPress Integration:

    I set the following settings:

    User Role Map

    WordPress Administrator – bbpress Keymaster

    WordPress Editor – bbpress Moderator

    WordPress Author – bbpress Member

    WordPress Contributor – bbpress member

    WordPress Subscriber – bbpress member

    – I save those settings.

    – Then I double check my settings listed below to make sure that I have it integrated with my WordPress MU SQL database:

    WordPress address (URL) –

    Blog address (URL) –

    Show advanced settings:

    – I fill out the information pertains to my first database which was for WordPress MU.

    User database host – localhost

    User database character set – utf8

    – All that seems to work fine, because I am able to login to wordpress mu my website and then go to the forums and it keeps me logged in.

    – I set the bbpress permalinks:

    – In bbpress I go to the discussion settings:

    Enable Pingbacks – Checked

    – In bbpress I go to the writing setting:

    Remote Publishing – XML-RPC – Checked

    – I go to general settings in BBPRESS

    bbPress address (URL) –

    Now back at my WPMU section:

    – Under Writing settings:

    Size of the post box – 40 lines

    Formatting – convert smilies – checked

    Wordpress should correct invalid nested xhtml – checked

    Remote Publishing:

    Atom Publishing – unchecked

    XML-RPC – Checked

    – Under discussion settings:

    Allow pingbacks – checked

    – Under permalinks for WPMU:

    custom: /%category%/%postname%/

    Now under Buddy press settings:

    Forum settings:

    – bbPress URL –

    – bbPress username – admin (which is the administrator account for WPMU and bbadmin is the main keymaster account for bbpress.)

    – Password – (Admin password for WPMU)

    – Cache requests – unchecked

    – Buddy Press Components – All Checked

    That’s pretty much it. After I create a new main group, it has the option for forum discussion group, and I check the box and it creates it just fine.

    But, whenever I go to try and post within that public group and I am obviuosly the main admin of that group, it comes up with an error:

    “There was an error posting that topic.”

    I have redone this like twice, created new SQL databases, new accounts, everything. I can’t imagine to tell you how many times I have reinstalled the bbpress. It doesn’t matter now which bbpress you have installed, I am still unable to post in the group forum discussions.

    Does anyone have any ideas of what I should do?

    I am so confused.

Viewing 6 replies - 1 through 6 (of 6 total)

  • flynn


    … Yeah, all that stuff he said.

    Seriously though, I’ve run out of ideas here too. I suppose we’re jumping the gun a bit using 1.01 before it is announced to work. But it seems like it should work ok.

    Any ideas?

    John James Jacoby


    Delete all of your the cookies for your website.

    Login through WordPress.

    Check that you are logged in on bbPress side.

    Attempt to access both administration panels.

    Check your sites cookies.

    Verify that the domain and/or site for the cookies are all identical.


    Login through bbPress.

    Check that you are logged in on WordPress side.

    Attempt to access both administration panels.

    Check your sites cookies.

    Verify that the domain and/or site for the cookies are all identical.


    If at any point through-out that process your sites cookies are NOT identical, it’s time to start fussing around with the cookie settings, and get them to line up.



    Well, now I am on a shared hosting service. I honestly have no idea how to check the cookies from the website directly even from the cpanel.

    I really do like WordPressMU and buddypress, and my main goal was to use buddy press’s group forum discussions, which utilize bbpress.

    I had this working before, and now it just keeps giving some error when I try to post a forum topic in the group discussions:

    “There was an error posting that topic.”

    Is there any error logs that buddypress, wordpress mu or bbpress produces that can at least show me what in the world is causing the error?

    I went into my CPANEL and there are no errors being shown in its error logs.

    I thought it was BBPRESS 1.0.1, so I downgraded to BBPRESS 1.0, and keep in mind I created a whole new sql database and username during this, and of course that didnt work.

    Then I downgraded to BBPRESS 1.0-RC3, and that didn’t work either. Nothing really has changed, except for bbpress. I have double checked the wp_config and bb_config keys and they all match up perfectly.

    However, the cookie hash key has remained the same throughout the entire situation, even after creating new databases and such.

    I honestly can’t think of anything else to really do here. I guess, I’m stuck.

    For now, I will keep trying, but I’m also just going to look for something else in the mean time to see if anything else is out there. I doubt it, but couldn’t hurt to look.

    I truly hope somebody has something else to add regarding my issues, because I honestly have no idea what to do next.



    One thing that might help is to put the following code on bb-config.

    $bb->bb_xmlrpc_allow_user_switching = true;

    I’ve tried to do this install from scratch for almost a week and have failed every time. But here are the steps I’ve been taking to get all of the newest releases to work together.

    As always – get backups before making any changes!!

    After you get wpmu & bp installed, install bbPress alpha 6 using my tutorial

    Steps 24-28 deal with cookies. Ignore those and instead, use the bbPress integration plugin to get the codes for all of that. Then, delete the plugin.

    After you get alpha 6 working correctly (group discussion works & login integration works), rename your bb-config file. Then overwrite the alpha 6 files with bbPress 1.0.1 Don’t delete the files!!! Overwrite them!! I think there’s a file being left behind that bp looks for & it isn’t included in the new version.

    After overwriting the files, navigate to your forums. (i.e. and you’ll be presented with an install screen. Enter your database info & on the next page it will tell you that the database is already there & you probably want to use the upgrade script. Go through & do that part.

    When finished with the database upgrade, open your old (renamed) bb-config file and copy all of your manually added codes over to your new bb-config file. Save & upload & all that good stuff.

    At this point, group discussion should work. If not, check your xml settings & make sure they’re still on. The buddypress enable plugin (found in forum settings) doesn’t need to be activated.

    *fingers crossed*



    $bb->bb_xmlrpc_allow_user_switching = true;


    Oh, thank god you exist in this world :)

    You were right…

    I actually made several mistakes, that I wanted to point out, and then my final post on this topic will lead to the url to where I found out how to fix my issues.

    But, thanks to TheEasyButton and John James Jacoby for their help. As it truly helped.

    Also a big thanks to Trent Adams for writing up that helpful tutorial found sticky on these buddypress forums.

    I had forgotten several steps

    – Add the code to the bottom of the bb-config file, that TheEasyButton mentioned above.

    – Disable forum discussions on new or existing group forums, and then re-enable them after they are created or working.

    – Needed to be signed in to both WPMU and BBPRESS as the administrator and not the key master. I had forgotten to set up my new admin account to have admin priviledges on the bbpress side. Woops… like big woops. :(

    There are two MAJOR things I wanted to point out.

    – If you tried to intall bbpress 1.0.1 by itself as fresh install, then I kept getting a major error that said, “Could not create new forum” during installing. I had to install bbpress 1.0 first to a new SQL database, then I removed all the files from the BBPRESS folder, and then uploaded the new bbpress 1.0.1 files. Which once I installed this new version, the SQL database was already set up for bbpress, so it just treated it as updating. Someone at BBPRESS really needs to fix that, as I’m sure many people are running into that problem.

    – The last thing I would like to mention, is that I didn’t really see on the tutorial article about helpful forum integration on the buddypress forums, about the cookies. I probably just missed that part, but it is very important that even when you overwrite your bbpress files, that when you over write your bb_config file, that you make sure the cookies are set and match wp_config cookies, of course with the bb_ prefix within the cookie parameters. Such as:








    define( ‘WP_AUTH_COOKIE_VERSION’, 1 );

    If you forget that last line, then it will definitely mess up everything too. But, the plugins placed into the right directories are the most important. This also doesn’t include that some buddy press plugins require that you move certain files from those plugins into your default buddy press theme. You also have to have a default buddy press theme in order to see everything properly too.

    One more thing,

    Hopefully, one day, someone will create an easier way to do all of this. Everything is so scattered all over the place, and right now, it can take a newbie several hours to get everything set up the way it is suppose to be. So, hopefully, somebody might create a program or something that will just automatically do everything for you or done through a central area at least.

    Thanks again for the help,

    my problem is solved.



Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Unable to post on my website in forum discussion’ is closed to new replies.
Skip to toolbar