Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatar Upload Issues

  • Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    There are numerous tickets in the trac and topics in the forums popping up. It seems lots of users are having issues uploading avatars with 1.1.2.

    I’ve tested this on two different environments with subdomains and subdirectory installs and cannot duplicate the problem myself. However, we’re aware that it’s an issue and will keep trying to resolve it.

    In the meantime, please route your avatar upload related discussion here. It will help us better monitor everyone’s experiences. Other topics regarding this issue will be locked and linked to this topic until it is resolved.

    Thanks everyone for being awesome and patient and understanding. :thumbup:

Viewing 25 replies - 26 through 50 (of 111 total)
  • Avatar of jwhitehurst
    jwhitehurst
    Participant

    @jwhitehurst

    I am having the same problem as nuprn1. no slash at the beginning. Now I’m building off of a single WP installation (not WPMU) as 1.2 (trunk) is supposed to support this.

    i added a note to this ticket:

    http://trac.buddypress.org/ticket/1294

    basically i found a few inconsistencies with file paths in the group section – also bp-groups-templatetags.php had a bunch of wrong file paths (double // in group urls) – the image path being sent to process did not contain the fullpath to the file – it would be just wp-content/uploads/etc instead of /home/user/domain/wp-content/uploads/etc)

    the image width check was failing (on bp-core-avatars.php)

    if ( getimagesize( $bp->avatar_admin->original['file'] ) > BP_AVATAR_ORIGINAL_MAX_WIDTH )

    to

    list($width, $height) = getimagesize( $bp->avatar_admin->originalfile? );
    if ( $width > BP_AVATAR_ORIGINAL_MAX_WIDTH )

    wp_crop_image ignores gif/png and saves everything as jpg (killing transparency – though to note the jquery cropper script does not support transparency during the UI selection)

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Unsticky-ing this from the front page. This should start to go away with 1.2.

    Avatar of abcde666
    abcde666
    Participant

    @erich73

    Avatar of jwhitehurst
    jwhitehurst
    Participant

    @jwhitehurst

    So I was having the problem with this on the single blog version of wordpress but not the multi user version on the same server. Then on the same server I created a brand new install of wordpress and buddypress and got it working there. I eventually found that the upload path that worked had /var/www/vhosts/url/httpdocs/wp-content/uploads but the one that did not work had just wp-content/uploads. once i changed this everything worked.

    Avatar of Michael Berra
    Michael Berra
    Participant

    @miguael

    Hmmmm – sorry to pick that up again… it is strange… I am running on trunk r2638 and when a user uploads a new avatar it just seems to mess things up… The small avatars show the just uploaded image, but the bigger (for updates and in the profile) stay on the old one from earlier BP-Versions).

    Can anyone help me with that strange issue???? Why is that? Any solutions?

    Avatar of Iva
    Iva
    Participant

    @supersonicsquirrel

    I’ve had the same problem as Diesel on all 1.2 release candidates. Furthermore, it also occurs in the case of the custom header…even though the images are actually uploaded and in the folders.

    Avatar of oldenburg
    oldenburg
    Member

    @oldenburg

    Hi,

    As a newbie i first want to thank the community for buddypress – I hope I will get everything to work properly.

    I cannot get images to work on my site http://www.nannys.dk

    When trying to upload an avatar to a profile i get to a page where i can crop. The image is not visible, so unfortunately I cannot crop. Standard avatars work fine.

    Also it does not collect Gravatar.

    When inserting an image to a blogpost, i cannot get to show the image. The image is uploaded, but not shown.

    I hope some friendly person can assist me?

    Best regards

    Avatar of audriusme
    audriusme
    Member

    @audriusme

    Hi,

    I also have the same problem like member oldenburg.

    Uploaded avatar url is http://mywebsite.com/blogs.dir/1/files/group-avatars/11/49824140ecc4ce7c95159eb47b725620-bpfull.jpg

    Path “wp-content” somewhere dissapear and image is not showing.

    I also can’t show image in post. The image is uploaded, but not showing.

    Please help.

    Avatar of audriusme
    audriusme
    Member

    @audriusme

    Now my uploaded image is showing. The problem was blogs.php file in wp-content. It was dissapeared in upgrade process. I uploaded it again and all avatars and blogs working fine

    Avatar of barrymonster
    barrymonster
    Participant

    @barrymonster

    I am having the same problem. Just uploaded BP 1.2.1 and when I upload an avatar it does not appear.

    Avatar of barrymonster
    barrymonster
    Participant

    @barrymonster

    I should also add that I see the images in the folder on the server, they just don’t appear on the site. I’ve tried various sizes and nothing works.

    Avatar of barrymonster
    barrymonster
    Participant

    @barrymonster

    I’m not seeing these blogs.php or blog.dir files i’ve seen spoken of so I am assuming they are for WPMU only ?

    I am running WP 2.85 and the upload url is /htdocs/wp-content/uploads/avatars/1

    As i’ve said before, the pics are in the album, they just don’t show up on the site. Permissions are set at 777 like it was suggested early.

    Avatar of jschires
    jschires
    Participant

    @jschires

    mine is holding on to the full address of the user and keep int the wp-content/ in the address:

    http://YOURSITE.com/members/bitter/profile/change-avatar/wp-content/uploads/avatars/18/bubble-guy-with-pen2.jpg

    Avatar of lyricalbiz
    lyricalbiz
    Participant

    @lyricalbiz

    My avatars are showing up, but the alignment is all vertical on the sidebar with no spacing . What I would love is an avatar block to show up. I’m also having the spacing issues (or lack of spacing) in my Members page.

    I’m using the BuddyPress Template plugin on BuddyPress 1.2.1 for WordPress single user 2.9.2. This site is a test site for a client project and it’s pretty much the last hurdle. The website is http://workingonthisnow.com/MHA

    I appreciate all the help! This forum is amazing.

    Avatar of hypergripe
    hypergripe
    Participant

    @hypergripe

    Hey JJJ;

    I would like to reiterate that @etiviti (rich!) posted a potential solution earlier, but I can’t figure out how/where to implement it in the bp core files.

    I am having the same problem that the avatar image is not being displayed, but when checking the code, (and using firebug) it is clear there is a simple ‘/’ missing from the image url path:

    PAGE SOURCE CODE WAS:

    <h5>Crop Your New Avatar</h5>

    <img id="avatar-to-crop" class="avatar" alt="Avatar to crop" src="wp-content/uploads/avatars/1/paul23.jpg"/>

    <div id="avatar-crop-pane">

    <img id="avatar-crop-preview" class="avatar" alt="Avatar preview" src="wp-content/uploads/avatars/1/paul23.jpg"/>

    </div>

    Notice there is no ‘/’ before the wp-content in the image src= call.

    SOURCE CODE SHOULD BE:

    <h5>Crop Your New Avatar</h5>

    <img id="avatar-to-crop" class="avatar" alt="Avatar to crop" src="/wp-content/uploads/avatars/1/paul23.jpg"/>

    <div id="avatar-crop-pane">

    <img id="avatar-crop-preview" class="avatar" alt="Avatar preview" src="/wp-content/uploads/avatars/1/paul23.jpg"/>

    </div>

    When I add the slash in front of wp-content in the src= call, the image(s) appear. Problem is, I can’t figure out how to get the core files to display the src= url properly.

    PLEASE HELP US ALL!!!

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Check out http://trac.buddypress.org/ticket/1970 and see if those fixes help?

    I know there are lots of different server setups and installation types we’re trying to account for, so it’s possible that something could need adjusting.

    Avatar of pandragon
    pandragon
    Member

    @pandragon

    Hi!

    I’m having problems with uploading avatars! I checked admin area in wordpress to see if upload works properly and it does. My problem is here http://www.pandragon.com/pan_avatar.jpg

    Also This is another silly question but is there a way I can only allow links to be links within my site? So if someone is talking about a game they can only link to a page in my site that has the game they are talking about?

    This is using own theme template with Bpress.

    Problem:

    When I upload it tries getting image from this path:

    “http://www.pandragon.com/home/pdks/public_html//avatars/2/avatar14885_1.jpg”

    If i get rid of “home/pdks/public_html/” the avatar is there! = http://www.pandragon.com/avatars/2/avatar14885_1.jpg

    How can I remove “home/pdks/public_html”

    Avatar of kenlefeb
    kenlefeb
    Participant

    @kenlefeb

    I have the same problem audriusme had, except that blogs.php is in the right place.

    If I use Firebug to edit the <img/> tags to add “wp-content” to the @src attribute, then everything works just as it should.

    I’m running on WPMU 2.9.1.1 and I just upgraded BP from 1.1.something to 1.2.1. In fact, since it wasn’t working, I also deactivated everything again and deleted BuddyPress altogether from the server and then did a manual install, just to be sure it wasn’t a problem with the upgrading process.

    I’ve searched both the BuddyPress forums and the WordPress forums for hours and it seems that all the other references to group avatars is “almost” similar to my problem, but not quite the same… until I saw audriusme’s post above about the missing “wp-content” in his <img/> tags. That’s exactly my problem.

    Any clues?

    Avatar of hypergripe
    hypergripe
    Participant

    @hypergripe

    Success!

    JJJ – I implemented your fix mentioned above and here: http://trac.buddypress.org/ticket/1970

    *****

    bp-core-avatars.php line 389

    Replace

    if ( !$path = get_option( 'upload_path' ) )<br />
    $path = WP_CONTENT_DIR . '/uploads';<br />

    With:

    if ( !$path = get_option( 'upload_path' ) )<br />
    $path = WP_CONTENT_DIR . '/uploads';<br />
    else<br />
    $path = ABSPATH . $path;</p>
    <p>

    and then in “Settings >> Miscellaneous” simply kept “Store uploads in this folder” as wp-content/uploads and in “Full URL path to files” added the full url path of the uploads folder: http://www.yoursite.com/wp-content/uploads

    Worked beautifully! Thanks so much all for all your help!!

    Avatar of Adijaffe
    adijaffe
    Participant

    @adijaffe

    I get to upload the file but then at the cropping phase I see broken links and I can’t do anything with the images. If not cropped, the images then don’t show up.

    Avatar of Beduino
    beduino
    Participant

    @beduino

    Hi,

    I have the same problem with a ”ported” buddypress installation [in site with several months] and I don’t have this problem with a fresh install [test site]

    I read and try fix above. I try change my URL/path in media settings [path to uploads] … nothing works

    Then I simply erase all data in misc options … [as I see in fresh install]

    And work!

    Maybe a coincidence … but work.

    all the best

    joao barroca

    Avatar of joshsadler
    joshsadler
    Member

    @joshsadler

    what about those of us that don’t use the wp-content/uploads directory but a custom directory for uploads. On my site is use http://www.SITE.com/files/

    How would I get this to work with the above-mentioned fix?

    Avatar of jesperpopma
    Jesper
    Participant

    @jesperpopma

    This worked for me:

    (see “Settings” >> “Miscellaneous”)

    Clear “Store uploads in this folder”-path

    Set “Full URL path to files” to absolute server path , e.g. “/home/_several_/_folder_/_levels_/wp-content/uploads”

    Avatar of joshsadler
    joshsadler
    Member

    @joshsadler

    that did the trick. Thanks!

Viewing 25 replies - 26 through 50 (of 111 total)

The topic ‘Avatar Upload Issues’ is closed to new replies.