Skip to:
Content
Pages
Categories
Search
Top
Bottom

Registration link redirects to home page

  • Avatar of dailynewarker
    dailynewarker
    Participant

    @dailynewarker

    Hey fellow Buddypressers. I raised this question at the WPMU forums and was directed here:

    http://mu.wordpress.org/forums/topic/16863

    I’m running WPMU 2.7.1 and BP 1.2. Clicking the “Create new account” link (or going directly to http://dailynewarker.com/register) just redirects the user back to the homepage. Here’s the home page, the registration link is at right (using the new BP theme).

    http://dailynewarker.com

    Here’s what I’ve tried to troubleshoot:

    * Deactivate all plugins (except BP)

    * Switched to BP 1.2 Default theme

    * Searched the interwebs for a couple of days and couldn’t find anyone else with this issue

    Nothing seems to help. I’m really at my wits end on this — appreciate the help!

    K

Viewing 10 replies - 26 through 35 (of 35 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    @mihaimihai

    You might want to post this on Trac:

    http://trac.buddypress.org/newticket

    Login with the same credentials you use here on bp.org.

    Avatar of Windhamdavid
    Windhamdavid
    Participant

    @windhamdavid

    @mihaimihai ~ were your registration page failing on secondary domains, sub- domains/directories only or also in the root and when you say “multiple sites on different domains”..how are you mapping the domains, if you don’t mind me asking?

    Avatar of jamland
    jamland
    Participant

    @jamland

    I have same problem.

    I’ve mapped site with Multi-site plugin, probably this is cause…

    @mihaimihai

    Big thanks!!

    I have added this filter to plugins/bp-custom.php and it seems to be ok now.

    Avatar of serveandshare
    serveandshare
    Member

    @serveandshare

    I am having this problem too. There is no registration page showing up. when I type in http://www.yoururl.com/register it redirects to the home page. Any suggestions?

    Avatar of serveandshare
    serveandshare
    Member

    @serveandshare

    I tried removing lines 17+18 of bp-core-signup.php /* If the user is logged in, redirect away from here */
    if ( is_user_logged_in() )

    but that didnt do anything

    On to the next fix…

    Avatar of serveandshare
    serveandshare
    Member

    @serveandshare

    @dailynewarker what do you mean when you said you pointed to your “real, production database”

    Avatar of serveandshare
    serveandshare
    Member

    @serveandshare

    Never mind I got it – I dont even know what I did. I checked it on a different computer and there it was. Then I checked it on the first computer and the sign up link was there. Wonder what that was all about.

    Avatar of Daniel Haim
    Daniel Haim
    Participant

    @danielhaim1

    I solved the issue by deleting BuddyPress from wp-content/plugin directory, and re uploading it. Good luck everyone!

    I had the same problem. I resolved this by
    1. Select Settings>General – Membership – Select “Anyone can register”
    2. Select Settings>Discussion Settings>Other comment settings – Select “Users must be registered and logged in to comment”
    3. Log out of administrator identity
    4. Clear browser cache
    5. Reload http://www.yoursite.com/register page

    Voila…hope it works for you others…

    good job, aomega. thank you!!!

Viewing 10 replies - 26 through 35 (of 35 total)

You must be logged in to reply to this topic.