Skip to:
Content
Pages
Categories
Search
Top
Bottom

Registration link redirects to home page

Viewing 10 replies - 26 through 35 (of 35 total)

  • r-a-y
    Moderator

    @r-a-y

    @mihaimihai

    You might want to post this on Trac:

    https://trac.buddypress.org/newticket

    Login with the same credentials you use here on bp.org.


    Windhamdavid
    Participant

    @windhamdavid

    @mihaimihai ~ were your registration page failing on secondary domains, sub- domains/directories only or also in the root and when you say “multiple sites on different domains”..how are you mapping the domains, if you don’t mind me asking?


    jamland
    Participant

    @jamland

    I have same problem.

    I’ve mapped site with Multi-site plugin, probably this is cause…

    @mihaimihai

    Big thanks!!

    I have added this filter to plugins/bp-custom.php and it seems to be ok now.


    serveandshare
    Member

    @serveandshare

    I am having this problem too. There is no registration page showing up. when I type in http://www.yoururl.com/register it redirects to the home page. Any suggestions?


    serveandshare
    Member

    @serveandshare

    I tried removing lines 17+18 of bp-core-signup.php /* If the user is logged in, redirect away from here */
    if ( is_user_logged_in() )

    but that didnt do anything

    On to the next fix…


    serveandshare
    Member

    @serveandshare

    @dailynewarker what do you mean when you said you pointed to your “real, production database”


    serveandshare
    Member

    @serveandshare

    Never mind I got it – I dont even know what I did. I checked it on a different computer and there it was. Then I checked it on the first computer and the sign up link was there. Wonder what that was all about.


    dh
    Participant

    @danielhaim1

    I solved the issue by deleting BuddyPress from wp-content/plugin directory, and re uploading it. Good luck everyone!

    I had the same problem. I resolved this by
    1. Select Settings>General – Membership – Select “Anyone can register”
    2. Select Settings>Discussion Settings>Other comment settings – Select “Users must be registered and logged in to comment”
    3. Log out of administrator identity
    4. Clear browser cache
    5. Reload http://www.yoursite.com/register page

    Voila…hope it works for you others…

    good job, aomega. thank you!!!

Viewing 10 replies - 26 through 35 (of 35 total)
  • The topic ‘Registration link redirects to home page’ is closed to new replies.
Skip to toolbar