Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress-Links 0.3 FINAL is here at last

  • Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    Sorry for yet another thread, but a lot of people are saying they are waiting for final to even test this out. Mods please feel free to close my other threads.

    I just tagged 0.3 final. Read all about it here:

    http://wordpress.org/extend/plugins/buddypress-links/

    If you are upgrading from the 0.2.x branch, read the readme.txt VERY carefully!

    Thanks to everyone who helped with this release! Also thanks to Andy for making BuddyPress Links a featured plugin.

Viewing 17 replies - 151 through 167 (of 167 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    I need some feedback from you guys on activity attachments.

    I have spent quite a bit of time working on the API for attaching content to activity items, and near the end here I am really struggling to make it work without modifying the core. The right way to do this is to integrate my API into the core starting with 1.4. Of course that is probably months away from release, which is a short term bummer.

    Do you guys want me to release 0.4 with all of the group integration and re-link features now? I really wanted to get activity attachments in there, but like I said its proving to be difficult and time consuming to make it work as a plugin.

    Avatar of idotter
    idotter
    Participant

    @idotter

    can you show us something to give you the feedback you want ? ;-)

    Activity-Stream-integration is a great thing your working on and i hope this will work soon.

    Avatar of arnonel
    arnonel
    Participant

    @arnonel

    release release release!

    cant wait :)

    I would love for you to release it now. I think having people beta test it (even part of it) will help make the whole much tighter for 1.4.

    Avatar of idotter
    idotter
    Participant

    @idotter

    does anyone knows when 1.3 will be released and the plans for 1.4 ? so you think that there will be a 1.4 before august?

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    @idotter

    i think this is the wrong thread to ask that question

    Avatar of Gpo1
    gpo1
    Participant

    @gpo1

    Please support foursquare Feeds…

    Avatar of gian-ava
    gian-ava
    Participant

    @gian-ava

    Hi, MrMaz!

    I can’t get the plugin to work. I mean, the stuff is there, but on my profile I don’t see the options to create links.

    First, I seem to have a big problem since I already had a page called “links”, so that page gets screwed up by the plugin.

    Also, I did put a folder called “bp-links-default” and created the following files to customize the HTML structure of those pages, to fit my layout:

    - index.php

    -create.php

    - single/home.php

    I got an error on the create page, line 22: require_once ‘single/forms/details.php’;

    I accessed that page by typing the URL/links/create.

    But as I told you I don’t have any button on the profile to access this page.

    Can you help me out?

    Here’s my setup:

    WP 2.9.2 (single)

    BP 1.2.3

    BP Template Pack installed

    WP is installed in a subfolder, with index.php in the root.

    Avatar of gian-ava
    gian-ava
    Participant

    @gian-ava

    Hi, MrMaz!

    I can’t get the plugin to work. I mean, the stuff is there, but on my profile I don’t see the options to create links.

    First, I seem to have a big problem since I already had a page called “links”, so that page gets screwed up by the plugin.

    Also, I did put a folder called “bp-links-default” and created the following files to customize the HTML structure of those pages, to fit my layout:

    - index.php

    -create.php

    - single/home.php

    I got an error on the create page, line 22: require_once ‘single/forms/details.php’;

    I accessed that page by typing the URL/links/create.

    But as I told you I don’t have any button on the profile to access this page.

    Can you help me out?

    Here’s my setup:

    WP 2.9.2 (single)

    BP 1.2.3

    BP Template Pack installed

    WP is installed in a subfolder, with index.php in the root.

    There is a conflict with the Simple Tags plugin (http://redmine.beapi.fr/projects/show/simple-tags). In the admin > manage links, under each link except the fist one I get the following errors:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in [path]/wp-content/plugins/simple-tags/inc/client.php on line 1310

    Warning: shuffle() expects parameter 1 to be array, null given in [path]//wp-content/plugins/simple-tags/inc/client.php on line 1311

    Warning: Invalid argument supplied for foreach() in[path]//wp-content/plugins/simple-tags/inc/client.php on line 1312

    This error also occurs in BuddyPress-Links 0.4.x.

    Just tested on the live site and there was no conflict. Not sure why.

    Is there a way to set the widget default to newest?

    Avatar of agrundner
    agrundner
    Member

    @agrundner

    @MrMaz Go for it. Release 0.4 with Group Links (not sure what re-links are). As for the group activity stream integration… I think we all can wait until it’s ready.

    FYI, I’d be happy to test the plugin you’ve got on my non-public development site.

    Avatar of MrMaz
    MrMaz
    Participant

    @mrmaz

    Avatar of PJ
    PJ
    Participant

    @pjnu

    @mrmaz , Could you please revise the Create a Link page. Categories are smushed together and like Microsoft Notepad when text isn’t wrapped to the page. It makes it difficult for users to add links in an orderly way.

    Instead, could each category be on a new line? Thank you.

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    Could you write in a recent tread ? This one was opened 8 mounth ago.
    MrMaz posted today to announce v. 05 !!!

Viewing 17 replies - 151 through 167 (of 167 total)

You must be logged in to reply to this topic.