Re: New “Skeleton Component” for developers
Don’t get me wrong–I really appreciate this. It’s great to be able to start out with a skeleton component.
That being said, it would be a better idea to name the component something else rather than “component”. Throughout all the files, we’re supposed to replace “component” with our own component name, however, there are instances such as the flag “current-component” that should not be renamed, creating confusion. Now we don’t know if we’re supposed to replace “component_id” or not.
It would have been better to name the thing “example”, or another word not currently used in the bp structure so we can see exactly see where the component name comes in.
I know the skeleton is created for us to learn the structure, I am just saying naming it “component” is confusing.
Also, the skeleton component does not work straight uploaded into the mu-plugins? It adds a nav menu options, but the screens do not work, nor the sub navs. Any ideas?